This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 107704 - top screen output corrupt on systems with more than 10G swap
top screen output corrupt on systems with more than 10G swap
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: procps (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 06:12 EDT by Jan Christiaan van Winkel
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-18 10:28:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a screenshot of top showing the problem (14.61 KB, image/gif)
2003-10-24 09:47 EDT, Jan Christiaan van Winkel
no flags Details
a screenshot of the new top, shows problem solved (6.22 KB, image/png)
2004-02-18 08:06 EST, Jan Christiaan van Winkel
no flags Details

  None (edit)
Description Jan Christiaan van Winkel 2003-10-22 06:12:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
If top is started on a system with more than 10G of swap, the swap-info line
overflows to the next line making the layout not as intended.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
start top on a system with >10G swap space

Actual Results:  line overflow on the swap line 

Expected Results:  a nice layout...

Additional info:
Comment 1 Jan Christiaan van Winkel 2003-10-24 09:47:45 EDT
Created attachment 95456 [details]
a screenshot of top showing the problem

The screendump clearly shows that the swap line is 1 character too long, thus
making top scroll the first line off the screen.
Comment 2 Alexander Larsson 2003-10-27 06:44:39 EST
This is with 80 columns?
Comment 3 Jan Christiaan van Winkel 2003-10-27 06:55:29 EST
Yes, indeed, this is with the default xterm width (and console width) of 80 columns.
Comment 4 Daniel Walsh 2004-02-11 08:50:04 EST
Could you check this with 3.1.15?

Dan
Comment 5 Jan Christiaan van Winkel 2004-02-18 08:06:26 EST
Created attachment 97785 [details]
a screenshot of the new top, shows problem solved

Note You need to log in before you can comment on or make changes to this bug.