Bug 107705 - top hides child processes of non-execed children
top hides child processes of non-execed children
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Brian Brock
:
: 107701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 06:21 EDT by Jan Christiaan van Winkel
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-29 07:48:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Christiaan van Winkel 2003-10-22 06:21:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
this is almost the same bug as number 107701, except in RH9, not only top is
wrong, but also ps.  In fedora core test3, only top is affected.

if a program fork()s but the child does not exec, top will not show it, and add
all CPU time to the parent.  Killing the parent will then show the child in top.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Compile rabbit.c:
                                                                                
#include <stdio.h>
#include <unistd.h>
                                                                                
int main() {
                                                                                
  fork();
  fork();
                                                                                
  printf("Rabbit PID=%d\n", getpid());
                                                                                
  while (1) {}
                                                                                
}
                                                                                
[jc@minioreo TEST]$ make rabbit
cc     rabbit.c   -o rabbit
[jc@minioreo TEST]$ ./rabbit &
[1] 12126
Rabbit PID=12128
Rabbit PID=12127
[jc@minioreo TEST]$ Rabbit PID=12129
Rabbit PID=12126



Actual Results:  Running top will now only show the parent (with PID 12126). 
Killing this, will show two other rabbits, but not the third...

Expected Results:  All children should show up in top.  Or at least there should
be an option to un-hide un-execed children...

Additional info:
Comment 1 Daniel Walsh 2004-02-11 08:51:26 EST
*** Bug 107701 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2004-03-25 10:44:37 EST
Is this fixed by procps-3.1.15?
Comment 3 Daniel Walsh 2004-03-29 07:48:09 EST
Not a problem in 3.2.0

Note You need to log in before you can comment on or make changes to this bug.