This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 107709 - Crash KSim with lm_sensors versions 2.7.0, 2.8.0 and 2.8.1
Crash KSim with lm_sensors versions 2.7.0, 2.8.0 and 2.8.1
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdeutils (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 08:13 EDT by McMCC
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 13:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Fix problem in KSim with the new version lm_sensors (2.7.0 and is higher) (295 bytes, patch)
2003-10-22 08:19 EDT, McMCC
no flags Details | Diff

  None (edit)
Description McMCC 2003-10-22 08:13:17 EDT
Description of problem: 
At a choice of an option lm_sensors in customizations KSim, leads to crash KSim. 
At usage lm_sensors versions 2.6.5 KSim works normal. 
 
How reproducible: 
Crash occurs because of distinctions of structure sensors_chip_name between versions  
lm_sensors 2.6.5 and 2.7.0 (or is higher), the plug-in ksim_sensors from kdeutils-3.1.4 works  
only with lm_sensors versions 2.6.5. For that that ksim_sensors would work with versions  
lm_sensors 2.7.0 and is higher, it is necessary to place this patch: 
 
--- 2/ksim/monitors/lm_sensors/sensorbase.h.orig        2003-05-07 15:49:05.000000000 
+0400 
+++ 2/ksim/monitors/lm_sensors/sensorbase.h     2003-10-22 12:19:38.000000000 +0400 
@@ -121,6 +121,7 @@ 
       char *prefix; 
       int bus; 
       int addr; 
+      char *busname; 
     }; 
 
     struct FeatureData
Comment 1 McMCC 2003-10-22 08:19:29 EDT
Created attachment 95380 [details]
Fix problem in KSim with the new version lm_sensors (2.7.0 and is higher)
Comment 2 Ngo Than 2004-10-26 13:16:43 EDT
it's already fixed in KDE upstream (KDE-3.3.x), which will be included
in FC3

Note You need to log in before you can comment on or make changes to this bug.