Bug 107754 - "DEL300f" Dell E171FP gets config'd for 1024x768, should be 1280x1024
"DEL300f" Dell E171FP gets config'd for 1024x768, should be 1280x1024
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Bill Nottingham
:
: 92221 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-22 14:43 EDT by Barry K. Nathan
Modified: 2014-03-16 22:39 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-04 17:42:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2003-10-22 14:43:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031007

Description of problem:
(I'm filing this against distribution because I'm not sure whether the guilty
party is anaconda, redhat-config-xfree86, firstboot, hwdata, or something else.)

A desktop system with a Dell E171FP monitor is being automatically configured
for 1024x768. My understanding (according to my boss at work; I didn't see this
myself) is that with Red Hat 9, there was some kind of prompt for the resolution
at some point (I'm guessing firstboot). I definitely saw such a prompt in
firstboot with Red Hat 8.0 on the same type of computer/monitor.

Since that prompt is no longer there, it is now more important that the monitor
is configured correctly automatically by the time the gdm login screen appears.



Version-Release number of selected component (if applicable):
Fedora Core 0.95

How reproducible:
Didn't try

Steps to Reproduce:

1. Install Fedora Core.
2. Notice monitor is fuzzy (as if in non-native resolution).
3. Run redhat-config-xfree86.
4. Change the resolution.
5. Log out and back in.
6. Notice that monitor is suddenly sharp.
    

Actual Results:  See the steps themselves

Expected Results:  Ideal expected result: 1280x1024 resolution
Less-than-ideal expected result: firstboot prompts for resolution

Additional info:

[root@vap12 root]# ddcprobe 

Videocard DDC probe results
Description:  ATI Technologies Inc. R100
Memory (MB):  32

Monitor DDC probe results
ID: DEL300f
Name: Dell E171FP
Horizontal Sync (kHZ): 30-80
Vertical Sync (HZ)  : 56-76
Width (mm): 340
Height(mm): 270

Is there any way to specify in hwdata or whatever that a monitor absolutely
should be set to a certain resolution by default if at all possible, even if it
happens to support other resolutions? The only way I can think of doing that
would involve adding a new field in MonitorsDB...

(BTW, MonitorsDB says "DEL300F" while ddcprobe says "DEL300f". Notice "F" vs.
"f". Would that cause any misbehavior?)
Comment 1 Brent Fox 2003-10-23 17:31:15 EDT
I'd rather not add a field in the MonitorsDB.  Probably a better solution is to
add a screen to firstboot to allow people to select their preferred resolution.
 It's too late for FC1, but we can shoot for FC2.
Comment 2 Barry K. Nathan 2003-10-23 19:01:02 EDT
Ok, that sounds good to me.
Comment 3 Seth Vidal 2003-11-19 02:13:26 EST
Should this be re-marked as enhancement for configuring resolution in
firstboot?

Comment 4 Brent Fox 2003-12-04 17:42:35 EST
Implemented in firstboot-1.3.3-1 and system-config-display-1.0.4-1.
Comment 5 Brent Fox 2003-12-05 17:42:01 EST
*** Bug 92221 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.