Bug 10778 - Problem with X-fonts after upgrading from RH 6.1 to RH 6.2
Summary: Problem with X-fonts after upgrading from RH 6.1 to RH 6.2
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-13 06:02 UTC by Joachim Backes
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-06 06:01:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Backes 2000-04-13 06:02:06 UTC
I updated my RedHat 6.1 to Redhat 6.2, and after this, a lot of
X11 Fonts were shown in a wrong manner (for example helvetica
fonts), that is, some sizes where represented by smaller ones.
Only a small subset (fixed for ex.) was shown correctly.

Then, I installed RH 6.2 completely new, then all fonts were
shown, but the layout was a ugly one (a very clear "stairs"
effect).

Regards
Joachim Backes

--

Joachim Backes <backes@rhrk.uni-kl.de>       | Univ. of Kaiserslautern
Computer Center, Supercomputing Division     | Phone: +49-631-205-2438
D-67653 Kaiserslautern, PO Box 3049, Germany | Fax:   +49-631-205-3056
---------------------------------------------+------------------------
WWW: http://sgi400.rhrk.uni-kl.de/home/mitarbeiter/backes.html

Comment 1 fred-m 2000-05-17 05:23:59 UTC
As for the problem of wrong fonts (Joachim's first paragraph), I had this
problem in two computers that I upgraded from 6.1 to 6.2 and found the cause.
The upgrade process forgot to add the 75 dpi fonts to /etc/X11/fs/config. (I
don't have 100 dpi fonts installed, this might apply to these fonts also).

Adding the 75 dpi font directory solved the problem.

Comment 2 Ben Stanley 2000-05-17 12:19:59 UTC
I also upgraded Red Hat 6.1 to 6.2. I checked my
/etc/X11/fs/config file, and I have the 75dpi and 100dpi
directories in the font path, but I still have grainy fonts.
The font I'm having most trouble with is -*-times.

Comment 3 Preston Brown 2000-07-13 19:26:22 UTC
what are the contents of your /etc/X11/fs/config file?

Comment 4 Ben Stanley 2000-07-17 00:01:11 UTC
My /etc/X11/fs/config file has the following:
------------------
#
# Default font server configuration file for Red Hat Linux 6.0
#

# allow a max of 4 clients to connect to this font server
client-limit = 4

# when a font server reaches its limit, start up a new one
clone-self = off

# alternate font servers for clients to use
#alternate-servers = foo:7101,bar:7102

# where to look for fonts
# Some of these are commented out, i.e. the TrueType and Type1
# directories in /usr/share, because they aren't forced to be
# installed alongside X.
#
catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
	/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
	/usr/X11R6/lib/X11/fonts/misc,
	/usr/X11R6/lib/X11/fonts/75dpi,
	/usr/X11R6/lib/X11/fonts/100dpi,
	/usr/X11R6/lib/X11/fonts/Type1,
	/usr/X11R6/lib/X11/fonts/Speedo,
	/usr/X11R6/lib/X11/fonts/freefont,
	/usr/local/mathematica/SystemFiles/Fonts/Type1
#	,
#	/usr/share/fonts/default/Type1,
#	/usr/share/fonts/ISO8859-2/misc:unscaled,
#	/usr/share/fonts/ISO8859-2/75dpi:unscaled,
#	/usr/share/fonts/ISO8859-2/100dpi:unscaled,
#	/usr/share/fonts/ISO8859-2/misc,
#	/usr/share/fonts/ISO8859-2/Type1,
#	/usr/share/fonts/ISO8859-2/75dpi,
#	/usr/share/fonts/ISO8859-2/100dpi

# in 12 points, decipoints
default-point-size = 120

# 100 x 100 and 75 x 75
default-resolutions = 75,75,100,100

# how to log errors
use-syslog = on

# listen on 7100 to service other font requirements.
port = 7100
----------------------

I have managed to fix most of the problems, but still have a problem with LyX, 
which uses the font specification -*-times by default.

Ben.


Comment 5 fred-m 2000-08-06 06:01:45 UTC
Just found the problem that I mentioned above. When I upgraded, I
moved /etc/X11/fs/config.rpmnew into /etc/X11/fs/config, without
noticing that config.rpmnew didn't have the path for 75dpi
fonts. My fault. (Hmm... but it would be nice if RPM had set
the font paths in config.rpmnew...)



Note You need to log in before you can comment on or make changes to this bug.