Bug 107803 - mozilla misapplies pref browser.display.screen_resolution
mozilla misapplies pref browser.display.screen_resolution
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
http://www.mozilla.org/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-23 01:36 EDT by Felix Miata
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 17:08:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot - 1.4.1-7 on severn beta3 @ 100 DPI pref (150.63 KB, image/png)
2003-10-23 01:45 EDT, Felix Miata
no flags Details
screenshot - 1.4.1-7 on severn beta3 @ 120 DPI pref (137.59 KB, image/png)
2003-10-23 01:45 EDT, Felix Miata
no flags Details
screenshot - 1.5 on severn beta3 @ 100 DPI pref (88.91 KB, image/png)
2003-10-23 01:46 EDT, Felix Miata
no flags Details
screenshot - 1.5 on severn beta3 @ 120 DPI pref (69.08 KB, image/png)
2003-10-23 01:46 EDT, Felix Miata
no flags Details
screenshot - Konqueror (145.01 KB, image/png)
2003-10-23 01:46 EDT, Felix Miata
no flags Details
screenshot - 1.5 on SuSE 8.1 @ 100 DPI pref (134.12 KB, image/png)
2003-10-23 01:46 EDT, Felix Miata
no flags Details
screenshot - 1.5 on SuSE 8.1 @ 120 DPI pref (100.52 KB, image/png)
2003-10-23 01:46 EDT, Felix Miata
no flags Details
screenshot - 1.5 on Win98 @ 096 DPI system setting (97.79 KB, image/png)
2003-10-23 01:46 EDT, Felix Miata
no flags Details
screenshot - 1.5 on Win98 @ 120 DPI system setting (83.32 KB, image/png)
2003-10-23 01:46 EDT, Felix Miata
no flags Details

  None (edit)
Description Felix Miata 2003-10-23 01:36:37 EDT
Description of problem:
browser.display.screen_resolution is the Mozilla pref designed to tailor
effective DPI to user needs so that fonts specified in points via css size
reasonably. All Mozilla versions I've tested increase the size of all fonts
specfied in points, except the current 1.4.1 version. This includes the
mozilla.org tarball of v1.5 run under severn beta3.

Version-Release number of selected component (if applicable):
1.4.1-7

How reproducible:
easy

Steps to Reproduce:
1-add 'user_pref("browser.display.screen_resolution", 100);' to user.js
2-start Mozilla 1.4.1 to indicated URL
3-take a screenshot of Mozilla window
4-close Mozilla
5-add 'user_pref("browser.display.screen_resolution", 120);' to user.js
6-start Mozilla 1.4.1 to indicated URL
7-take a screenshot of Mozilla window
8-close Mozilla
9-compare screenshots
10-Repeat steps above, but substitute mozilla.org's tarball of v1.5
11-Repeat steps 1-8 above, but use mozilla.org's tarball of v1.5 or v1.4.1 on
SuSE, Mandrake, OS/2 and/or Win98 (in Win98 and OS/2, DPI must be changed via
system settings rather than user.js)
    
Actual results:
1-page text sized in points in both screenshots of 1.4.1-7 is identical
2-page text sized in points in all other screenshots is larger at 120DPI than at
100DPI
3-page text overall is sized smaller in 1.4.1-7 than the others

Expected results:
1-page text sized in points is larger at 120DPI than at 100DPI in every
screenshot pair
2-page text overall is sized similarly in all screenshots, depending on the
actual fonts available to Mozilla

Additional info:
1-dbaron & bz on moznet are of the opinion that this is a Mozilla rather than a
Fedora bug. I tried contacting blizzard for an opinion about this, but was
unsuccessful.
2-In every Mozilla screenshot following, the default 16px font size setting was
used. The Konqueror shot was made on a fresh severn3 install with no system
settings or Konq specific changes having been made.
Comment 1 Felix Miata 2003-10-23 01:45:42 EDT
Created attachment 95414 [details]
screenshot - 1.4.1-7 on severn beta3 @ 100 DPI pref
Comment 2 Felix Miata 2003-10-23 01:45:53 EDT
Created attachment 95415 [details]
screenshot - 1.4.1-7 on severn beta3 @ 120 DPI pref
Comment 3 Felix Miata 2003-10-23 01:46:00 EDT
Created attachment 95416 [details]
screenshot - 1.5 on severn beta3 @ 100 DPI pref
Comment 4 Felix Miata 2003-10-23 01:46:07 EDT
Created attachment 95417 [details]
screenshot - 1.5 on severn beta3 @ 120 DPI pref
Comment 5 Felix Miata 2003-10-23 01:46:16 EDT
Created attachment 95418 [details]
screenshot - Konqueror
Comment 6 Felix Miata 2003-10-23 01:46:26 EDT
Created attachment 95419 [details]
screenshot - 1.5 on SuSE 8.1 @ 100 DPI pref
Comment 7 Felix Miata 2003-10-23 01:46:33 EDT
Created attachment 95420 [details]
screenshot - 1.5 on SuSE 8.1 @ 120 DPI pref
Comment 8 Felix Miata 2003-10-23 01:46:41 EDT
Created attachment 95421 [details]
screenshot - 1.5 on Win98 @ 096 DPI system setting
Comment 9 Felix Miata 2003-10-23 01:46:50 EDT
Created attachment 95422 [details]
screenshot - 1.5 on Win98 @ 120 DPI system setting
Comment 10 Felix Miata 2003-10-30 20:30:53 EST
See also Mozilla bug http://bugzilla.mozilla.org/show_bug.cgi?id=197037 for
additional analysis of this situation.
Comment 11 Felix Miata 2005-09-29 18:51:21 EDT
I believe the comment 10 bug fix fixed this. It seems to be fine now in
mozilla-1.7.8-2 in FC4.
Comment 12 John Thacker 2006-10-28 17:08:52 EDT
Closing.
Comment 13 Matěj Cepl 2007-04-27 05:57:53 EDT
*** Bug 238108 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.