Bug 107829 - DRI-accelerated applications crash with XFree86-4.3.0-40 on i845G
Summary: DRI-accelerated applications crash with XFree86-4.3.0-40 on i845G
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-23 14:42 UTC by Andrew Novikov
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-16 16:58:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:406 normal SHIPPED_LIVE Updated XFree86 packages are available 2003-12-11 05:00:00 UTC

Description Andrew Novikov 2003-10-23 14:42:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
When I start e.g. glxgeras it segfaults. Here is the backtrace:

(gdb) bt
#0  0x4040486b in _mesa_test_os_sse_exception_support () from /usr/X11R6/lib/modules/dri/i830_dri.so
#1  0x404045a1 in check_os_sse_support () from /usr/X11R6/lib/modules/dri/i830_dri.so
#2  0x404046b1 in _mesa_init_all_x86_transform_asm () from /usr/X11R6/lib/modules/dri/i830_dri.so
#3  0x4037758b in _math_init () from /usr/X11R6/lib/modules/dri/i830_dri.so
#4  0x403038ba in one_time_init () from /usr/X11R6/lib/modules/dri/i830_dri.so
#5  0x40305c24 in _mesa_initialize_context () from /usr/X11R6/lib/modules/dri/i830_dri.so
#6  0x40306069 in _mesa_create_context () from /usr/X11R6/lib/modules/dri/i830_dri.so
#7  0x40408c0a in i830CreateContext () from /usr/X11R6/lib/modules/dri/i830_dri.so
#8  0x402f16af in driCreateContext () from /usr/X11R6/lib/modules/dri/i830_dri.so
#9  0x4004cbc8 in _glapi_noop_enable_warnings () from /usr/X11R6/lib/libGL.so.1
#10 0x4004cd1e in glXCreateContext () from /usr/X11R6/lib/libGL.so.1
#11 0x0804a3e6 in XOpenDisplay ()
#12 0x0804a6b2 in XOpenDisplay ()
#13 0x401a5748 in __libc_start_main () from /lib/tls/libc.so.6

The above doesn't happen when I use XFree86-4.3.0-2.
I use an upgraded version of Red Hat Linux 9 with 2.6.0-test8 kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.0-test8.0 glibc-2.3.2-98 XFree86-4.3.0-40

How reproducible:
Always

Steps to Reproduce:
Try to start glxgeras on i845G hardware with DRI turned on.    

Additional info:

Comment 1 Mike A. Harris 2003-10-23 22:18:33 UTC
Is the problem reproduceable with the officially supported 2.4.x kernel?

Comment 2 Andrew Novikov 2003-10-24 09:22:44 UTC
No, I can't reproduce the problem with the official kernel-2.4.20-20.9. 

Comment 3 Mike A. Harris 2003-10-24 17:31:33 UTC
Ok thanks, this is a known issue with the combination of current XFree86
Mesa and 2.6.x kernels being incompatible with each other.  Some time
after Fedora Core 1 is shipped, this issue will be investigated deeper
as we don't support 2.6.x officially at this time.



*** This bug has been marked as a duplicate of 106566 ***

Comment 4 Jay Turner 2004-01-16 16:58:32 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-406.html



Note You need to log in before you can comment on or make changes to this bug.