Bug 107908 - aic7xxx fails to configure device (IBM HDD DPSS-318350M)
aic7xxx fails to configure device (IBM HDD DPSS-318350M)
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-24 07:00 EDT by Dirk Gfroerer
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 12:44:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Gfroerer 2003-10-24 07:00:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030910

Description of problem:
While booting the machine the following warning message scrolls by:

scsi0:A:3:0: DV failed to configure device.  Please file a bug report against
this driver.
scsi0:A:12:0: DV failed to configure device.  Please file a bug report 

Full part of SCSI initialization

scsi0 : Adaptec AIC7XXX EISA/VLB/PCI SCSI HBA DRIVER, Rev 6.2.36
        <Adaptec 29160N Ultra160 SCSI adapter>
        aic7892: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs

Starting timer : 0 0
blk: queue e7808614, I/O limit 4095Mb (mask 0xffffffff)
(scsi0:A:0): 80.000MB/s transfers (40.000MHz, offset 31, 16bit)
(scsi0:A:1): 160.000MB/s transfers (80.000MHz DT, offset 63, 16bit)
scsi0:A:3:0: DV failed to configure device.  Please file a bug report against
this driver.
(scsi0:A:6): 20.000MB/s transfers (20.000MHz, offset 16)
scsi0:A:12:0: DV failed to configure device.  Please file a bug report against
this driver.
  Vendor: IBM       Model: DNES-309170W      Rev: SA30
  Type:   Direct-Access                      ANSI SCSI revision: 03
Starting timer : 0 0
blk: queue c2a85c14, I/O limit 4095Mb (mask 0xffffffff)
  Vendor: IBM       Model: DPSS-318350N      Rev: S96H
  Type:   Direct-Access                      ANSI SCSI revision: 03
Starting timer : 0 0
blk: queue e7809c14, I/O limit 4095Mb (mask 0xffffffff)
(scsi0:A:3): 160.000MB/s transfers (80.000MHz DT, offset 63, 16bit)
  Vendor: IBM       Model: DPSS-318350M      Rev: S80D
  Type:   Direct-Access                      ANSI SCSI revision: 03
Starting timer : 0 0
blk: queue e7809a14, I/O limit 4095Mb (mask 0xffffffff)
  Vendor: TOSHIBA   Model: DVD-ROM SD-M1401  Rev: 1008
  Type:   CD-ROM                             ANSI SCSI revision: 02
Starting timer : 0 0
blk: queue e7809814, I/O limit 4095Mb (mask 0xffffffff)
(scsi0:A:12): 160.000MB/s transfers (80.000MHz DT, offset 63, 16bit)
  Vendor: IBM       Model: DPSS-318350M      Rev: S80D
  Type:   Direct-Access                      ANSI SCSI revision: 03
Starting timer : 0 0
blk: queue e7809614, I/O limit 4095Mb (mask 0xffffffff)
scsi0:A:0:0: Tagged Queuing enabled.  Depth 32
scsi0:A:1:0: Tagged Queuing enabled.  Depth 32
scsi0:A:3:0: Tagged Queuing enabled.  Depth 32
scsi0:A:12:0: Tagged Queuing enabled.  Depth 32
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi disk sdb at scsi0, channel 0, id 1, lun 0
Attached scsi disk sdc at scsi0, channel 0, id 3, lun 0
Attached scsi disk sdd at scsi0, channel 0, id 12, lun 0


Version-Release number of selected component (if applicable):
kernel-2.4.21-4.EL

How reproducible:
Always

Steps to Reproduce:
1. Reboot machine
 

Actual Results:  warning message is displayed.

Expected Results:  no warning message is being displayed.

Additional info:

[root@ghlx03 root]# lsmod
Module                  Size  Used by    Not tainted
parport_pc             19076   1  (autoclean)
lp                      9028   0  (autoclean)
parport                37088   1  (autoclean) [parport_pc lp]
autofs                 13364   0  (autoclean) (unused)
3c59x                  30928   1 
sr_mod                 18104   0  (autoclean)
cdrom                  33696   0  (autoclean) [sr_mod]
floppy                 58160   0  (autoclean)
microcode               4724   0  (autoclean)
keybdev                 2976   0  (unused)
mousedev                5524   0 
hid                    22212   0  (unused)
input                   5888   0  [keybdev mousedev hid]
usb-uhci               26412   0  (unused)
usbcore                79392   1  [hid usb-uhci]
ext3                   91592   5 
jbd                    52336   5  [ext3]
aic7xxx               163440   7 
sd_mod                 13744  14 
scsi_mod              108840   3  [sr_mod aic7xxx sd_mod]
Comment 1 Tom Coughlan 2003-10-27 11:16:10 EST
Justin, do you recognize this problem?

Driver 6.2.36, "DV failed to configure device.  Please file a bug report against
this driver."
Comment 2 Justin T. Gibbs 2003-10-27 12:24:20 EST
The spurious error report is caused by the IBM DPSS-318350M failing to
support an echo buffer for Domain Validation.  This is required by the
U160 spec.  There is a firmware update for these drives that enables
proper echo-buffer support.

Future versions of the driver will not print this diagnostic for missing
echo-buffer support since it generates too much email for little benefit.
Domain Validation rarely finds configuration issues at U160 speeds.
Comment 3 Tom Coughlan 2003-10-27 12:44:19 EST
Thanks Justin.

I'll close this bug. The firmware update should fix it.

Note You need to log in before you can comment on or make changes to this bug.