Bug 107935 - inaccessible files and folders due to etc/sysconfig i18n
Summary: inaccessible files and folders due to etc/sysconfig i18n
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: nautilus   
(Show other bugs)
Version: rawhide
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-24 18:06 UTC by Mike
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 02:10:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike 2003-10-24 18:06:44 UTC
Description of problem:
German umlauts created by Windows don't show correctly. You can't access files
and folders.

Version-Release number of selected component (if applicable):
Error present since Rh8 through Fedora

How reproducible:
Konqueror, any other application except Mozilla doesn't display the correct
file- and foldernames

Steps to Reproduce:
1. open applications, go to a vfat partition nad you'll see it.
2.
3.
    
Actual results:
Inaccessible files and folders

Expected results:
Access them with a correct "i18n"-file

Additional info:
FIX:
You must edit the /etc/sysconfig i18n file correctly.
My version now looks like:
LANG="de_DE"
LC_MONETARY="de_DE"
LC_MESSAGES="de_DE"
SYSFONTACM="iso15"
LC_ADDRESS="de_DE"
LC_COLLATE="de_DE"
SYSFONT="lat0-16"
LC_PAPER="de_DE"
LANGUAGE="de_DE:de"
LC_NUMERIC="de_DE"
LC_IDENTIFICATION="de_DE"
LC_CTYPE="de_DE"
LC_TIME="de_DE"
LC_NAME="de_DE"
LC_MEASUREMENT="de_DE"
LC_TELEPHONE="de_DE"
SYSFONT="latarcyrheb-sun16"

Everything works fine now.

Comment 1 Kai Thomsen 2003-10-24 21:55:17 UTC
Unicode support is the future, so the long-term solution is the one described in 
Bug 107834.

Comment 2 Bill Nottingham 2003-10-27 02:10:48 UTC
You need to have your filenames match your current locale, or mount
them in such a way that their filenames are converted.

Comment 3 Alexander Larsson 2003-10-27 11:47:13 UTC
Nautilus (and the rest of gnome) assumes filenames are in UTF8 unless
G_BROKEN_FILENAMES is set in the environment, then they are expected to be
encoded according to the current locale.

See for instance: http://www.gtk.org/gtk-2.2.0-notes.html


Note You need to log in before you can comment on or make changes to this bug.