Bug 107936 - Mesa assembler code uses ENTER/LEAVE instructions for a performance hit.
Summary: Mesa assembler code uses ENTER/LEAVE instructions for a performance hit.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-24 18:16 UTC by Mike A. Harris
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-20 17:06:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike A. Harris 2003-10-24 18:16:30 UTC
Mesa assembler code uses ENTER/LEAVE instructions which I noticed while
reviewing debugger output.  This incurs severe performance loss due to these
instructions being implemented in microcode according to Intel docs.

This should be optimized to remove ENTER/LEAVE and save/restore registers
manually, etc.


Note You need to log in before you can comment on or make changes to this bug.