Bug 107974 - Hang when pcmcia started with card present, if pcmcia started then card inserted, insertion not detected, card remains unpowered, no beep.
Hang when pcmcia started with card present, if pcmcia started then card inser...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-25 07:58 EDT by Christopher Johnson
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: kernel-2.6.1-1.65
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-14 17:37:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Excerpt from /var/log/messages when hang occured (1.14 KB, text/plain)
2003-10-25 08:16 EDT, Christopher Johnson
no flags Details
All "ACPI" messages grep'd from /var/log/dmesg (1.79 KB, text/plain)
2003-10-25 08:21 EDT, Christopher Johnson
no flags Details
Output of lspci -vv (7.59 KB, text/plain)
2003-10-25 08:22 EDT, Christopher Johnson
no flags Details
Output of dmidecode (6.27 KB, text/plain)
2003-10-25 08:23 EDT, Christopher Johnson
no flags Details
Output from pirqdmp (by Len Brown - Intel) (1.03 KB, text/plain)
2003-10-25 08:25 EDT, Christopher Johnson
no flags Details
/etc/pcmcia/config.opts (2.64 KB, text/plain)
2003-10-25 09:01 EDT, Christopher Johnson
no flags Details
Excerpt from /var/log/messages when hang occured (19.97 KB, text/plain)
2003-12-13 21:30 EST, Christopher Johnson
no flags Details
Output of lspci -vv (7.59 KB, text/plain)
2003-12-13 21:31 EST, Christopher Johnson
no flags Details
All ACPI messages grep'd from dmesg (2.12 KB, text/plain)
2003-12-13 21:32 EST, Christopher Johnson
no flags Details
Output of dmidecode (12.19 KB, text/plain)
2003-12-13 21:33 EST, Christopher Johnson
no flags Details
Output from pirqdmp (by Len Brown - Intel) (1.03 KB, text/plain)
2003-12-13 21:35 EST, Christopher Johnson
no flags Details
Working config.opts for Compaq Presario 2100. (2.68 KB, text/plain)
2004-02-14 17:36 EST, Christopher Johnson
no flags Details

  None (edit)
Description Christopher Johnson 2003-10-25 07:58:04 EDT
Description of problem: I have a Compaq Presario 2100z laptop and have a problem
with system hang trying to use a pcmcia card, or with detection that card is
inserted, depending on procedure used.  Laptop nominally has RH9 on it, but I
upgraded the kernel to 2.4.22-1.2061.nptl athlon from rawhide. I believe that is
the kernel from FC1beta2, but please correct this bug if I am wrong. If built-in
ethernet is connected and interface up, then I insert wireless pcmcia card, then
I do service pcmcia restart, card works normally.  All other procedures to use
card do not work, and unfortunately a wired connection is not present when using
wireless normally, so it's not a practical work-around ;)


Version-Release number of selected component (if applicable):
2.4.22-1.2061.nptl (athlon)

How reproducible:
Two different problem scenarios, both reproducable.

Steps to Reproduce:
1. insert wireless pcmcia card
2. do not connect built-in ethernet port to a network
3. boot system
4. system hangs solid when pcmcia starts, corrected only by forcing power off
or
1. boot system without pcmcia card, and built-in ethernet port not connected
2. after boot, insert wireless pcmcia card
3. insertion is not detected, card remains unpowered, no beep heard
4. if I do service pcmcia restart a hang occurs as in first scenario

Actual results:
system hangs

Expected results:
pcmcia card works normally

Additional info:
Comment 1 Christopher Johnson 2003-10-25 08:16:30 EDT
Created attachment 95474 [details]
Excerpt from /var/log/messages when hang occured

In this case I inserted the card, then restarted pcmcia service, whereupon the
card was detected, modules loaded, and system hung.
Comment 2 Christopher Johnson 2003-10-25 08:21:10 EDT
Created attachment 95475 [details]
All "ACPI" messages grep'd from /var/log/dmesg

I am using kernel boot param acpi=on, and loading acpi modules since this pc
relies on that for interrupt management and power management.
Comment 3 Christopher Johnson 2003-10-25 08:22:19 EDT
Created attachment 95476 [details]
Output of lspci -vv
Comment 4 Christopher Johnson 2003-10-25 08:23:04 EDT
Created attachment 95477 [details]
Output of dmidecode
Comment 5 Christopher Johnson 2003-10-25 08:25:16 EDT
Created attachment 95478 [details]
Output from pirqdmp (by Len Brown - Intel)
Comment 6 Christopher Johnson 2003-10-25 09:01:13 EDT
Created attachment 95479 [details]
/etc/pcmcia/config.opts
Comment 7 Michael K. Johnson 2003-10-27 11:35:21 EST
acpi=on, adding acpi CC
Comment 8 Christopher Johnson 2003-11-29 10:50:08 EST
I performed a clean install of FC1 on this laptop, and applied all
updates, and this problem still exists.
Comment 9 Christopher Johnson 2003-12-13 21:09:40 EST
I have updated to latest BIOS (KA.M1.50), but PCMCIA Still hangs the
system requiring cycling of power with kernel-2.4.22-1.2129.nptl and
kernel-2.6.0-0.test11.1.102.  I will attach revised syslog, lspci -vv,
pirqdmp, and dmidecode. What can I do to provide additional
information which will lead to a resolution of this problem?
Comment 10 Christopher Johnson 2003-12-13 21:30:07 EST
Created attachment 96514 [details]
Excerpt from /var/log/messages when hang occured
Comment 11 Christopher Johnson 2003-12-13 21:31:13 EST
Created attachment 96515 [details]
Output of lspci -vv
Comment 12 Christopher Johnson 2003-12-13 21:32:48 EST
Created attachment 96516 [details]
All ACPI messages grep'd from dmesg
Comment 13 Christopher Johnson 2003-12-13 21:33:21 EST
Created attachment 96517 [details]
Output of dmidecode
Comment 14 Christopher Johnson 2003-12-13 21:35:39 EST
Created attachment 96518 [details]
Output from pirqdmp (by Len Brown - Intel)
Comment 15 Christopher Johnson 2004-02-14 17:36:26 EST
Created attachment 97676 [details]
Working config.opts for Compaq Presario 2100.

Problem is fixed by several changes:
BIOS update to KA.M1.54 which gave card controller its own interrupt.
Kernel update to kernel-2.6.1-1.65.
And minor tweak to config.opts because I had spurious interrupts disrupting
state of the wireless interface.  See attached config.opts with which yenta and
orinoco_cs now share irq 10.

Note You need to log in before you can comment on or make changes to this bug.