Bug 107981 - Up2date fails when --register pased as option
Up2date fails when --register pased as option
Status: CLOSED CANTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-25 11:14 EDT by Alan Sanderson
Modified: 2007-04-18 12:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 15:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of 'strace -o strace.out /usr/sbin/up2date --register' (272.32 KB, text/plain)
2003-11-04 04:36 EST, Alan Sanderson
no flags Details
Output of 'strace -o strace.out /usr/sbin/up2date --register' (5/11/2003) (272.39 KB, text/plain)
2003-11-05 00:05 EST, Alan Sanderson
no flags Details

  None (edit)
Description Alan Sanderson 2003-10-25 11:14:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-AU; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
From a shell enter up2date --register & and it pauses for a seocond and then
does nothing.

Version-Release number of selected component (if applicable):
4.1.9-1

How reproducible:
Always

Steps to Reproduce:
1. See description
2.
3.
    

Actual Results:  Nothing

Expected Results:  Registration box is spawned

Additional info:
Comment 1 Alan Sanderson 2003-10-30 06:24:35 EST
Problem also observed with up2date-4.1.12-1
Comment 2 Alan Sanderson 2003-11-03 00:19:49 EST
Dito with up2date-4.1.14-2
Comment 3 Adrian Likins 2003-11-03 15:20:40 EST
is behaviour the same when invoked from the commandline as:


/usr/sbin/up2date --register

if so, could you attach the output ("strace.out") of:

strace -o strace.out /usr/sbin/up2date --register
Comment 4 Alan Sanderson 2003-11-04 04:36:03 EST
Created attachment 95703 [details]
Output of 'strace -o strace.out /usr/sbin/up2date --register'

'/usr/sbin/u2date --register' had same result. Attaching output of 'strace -o
strace.out /usr/sbin/up2date --register'
Comment 5 Adrian Likins 2003-11-04 15:25:45 EST
hmm. looks like librpm is exit()'ing for some reason. Off hand,
I don't know why.

Could you try a `rpm --rebuilddb` and try it again? 

if that doesnt fix it, I'll have to reassign to `rpm`.
Comment 6 Alan Sanderson 2003-11-05 00:00:36 EST
The problem didn't present itself on the system in question with
up2date-3.1.23.2-1, I've only noticed it since up2date-4.1.*.
Anyway I ran rpm --rebuilddb and then /usr/sbin/up2date --register and
got the same result.
Comment 7 Alan Sanderson 2003-11-05 00:05:05 EST
Created attachment 95724 [details]
Output of 'strace -o strace.out /usr/sbin/up2date --register' (5/11/2003)

Ran 'strace -o strace.out /usr/sbin/up2date --register' again and am attaching
output. I don't know if that will help, but I figured it couldn't hurt.
Comment 8 Alan Sanderson 2003-11-05 12:19:18 EST
Same deal with up2date-4.1.16-1
Comment 9 Jeff Johnson 2005-10-25 20:42:55 EDT
This is an up2date, not an rpm, problem.
Comment 10 Bill Nottingham 2006-08-07 21:56:56 EDT
'Red Hat Raw Hide' refers to the development tree for Red Hat Linux.
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues were not resolved in a more
timely manner. However, we do want to make sure that important 
don't slip through the cracks. If these issues are still present
in a current release, such as Fedora Core 5, please move these
bugs to that product and version. Note that any remaining Red Hat
Raw Hide bugs will be closed as 'CANTFIX' on September 30, 2006.
Thanks again for your help.
Comment 11 Bill Nottingham 2006-10-18 15:38:00 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.