Bug 108001 - (SATA) SMP ACPI does not config SATA interrupts right on i875P
(SATA) SMP ACPI does not config SATA interrupts right on i875P
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
: 108002 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-25 20:59 EDT by Jon Smirl
Modified: 2013-07-02 22:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-07 00:56:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Smirl 2003-10-25 20:59:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031023

Description of problem:
I have SCSI and the ICH5 SATA drivers built into my kernel. Uniprocessor this
works fine. The OS install kernel also works. 

The default SMP kernel does not work. Same for a custom one I have built trying
to select all the appropriate options. The SATA driver comes up and assigns the
SATA drive IRQ 17. When the partition is probed I get DMA timeouts. I am pretty
certain that there is some problem with ACPI getting IRQ 17 configured
correctly. I can't capture the dmesg since it won't boot.

2.6-test9 works without problem smp and uni. 2.6 requires full ACPI support for
SATA to work in SMP mode. I am using SCSI ATA support in test9 too.

Machine is Dell PE400SC with one SATA and one IDE drive. Hyperthreaded CPU used
for SMP mode. i875P, P4 2.8C. ICH5 no hardware RAID.

See this bug for lots of ACPI info about my machine:
http://bugzilla.kernel.org/show_bug.cgi?id=1173

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2108.nptl

How reproducible:
Always

Steps to Reproduce:
Boot machine with SMP kernel
    

Additional info:
Comment 1 Jon Smirl 2003-10-25 21:02:38 EDT
*** Bug 108002 has been marked as a duplicate of this bug. ***
Comment 2 Jon Smirl 2003-10-29 14:41:59 EST
Just checked 2110 SMP. Still won't boot hyperthreaded on Dell PE400SC/Dimension
8300 (same motherboard) with SATA drives. This is probably an ACPI interrupt
assignment issue.
Comment 3 Jon Smirl 2003-12-16 16:31:20 EST
Using new A04 BIOS from Dell I can make this work with a custom
kernel. Stock kernel does not have libata SATA support built in.
Comment 4 Jeff Garzik 2004-01-12 14:35:16 EST
So, the problem is gone now?
Comment 5 Jon Smirl 2004-06-14 14:28:28 EDT
Standard kernel-smp-2.6.6-1.427 now boots ok on SATA. I haven't tried
2.4 lately.

Note You need to log in before you can comment on or make changes to this bug.