Bug 108007 - 2.6 kernel not compiled with CONFIG_FRAMEBUFFER_CONSOLE
Summary: 2.6 kernel not compiled with CONFIG_FRAMEBUFFER_CONSOLE
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL: http://people.redhat.com/arjanv/2.5/R...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-26 03:40 UTC by rudi
Modified: 2007-04-18 16:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-16 17:57:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rudi 2003-10-26 03:40:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031023

Description of problem:
The 2.6 kernel is not compiled with CONFIG_FRAMEBUFFER_CONSOLE enabled.
I am not sure if this was simply overlooked or if it was done on purpose
to avoid some severe bug.

Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test8.1.66

How reproducible:
Always

Steps to Reproduce:
1. Enable the framebuffer in the kernel boot command line
    

Actual Results:  Behold the sheer beauty of a completely blank screen, because
code to
support the console over fb hasn't been compiled into the kernel. Wait
for X to finally offer you some degree of interaction with the machine.

Expected Results:  A shiny boot logo, the usual boot blurb and a working console.

Additional info:

Comment 1 Dave Jones 2003-12-16 17:57:03 UTC
Fixed in rawhide.

(17:59:33:davej@delerium:linux-2.6.0-test11)$ grep
CONFIG_FRAMEBUFFER_CONSOLE configs/*
configs/config-generic:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/kernel-2.6.0-test11-i586.config:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/kernel-2.6.0-test11-i586-smp.config:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/kernel-2.6.0-test11-i686-bigmem.config:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/kernel-2.6.0-test11-i686.config:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/kernel-2.6.0-test11-i686-smp.config:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/kernel-2.6.0-test11-x86_64.config:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/kernel-2.6.0-test11-x86_64-smp.config:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/temp-x86_64-generic:CONFIG_FRAMEBUFFER_CONSOLE=y
configs/temp-x86-generic:CONFIG_FRAMEBUFFER_CONSOLE=y



Note You need to log in before you can comment on or make changes to this bug.