Bug 108011 - SHIFT_HZ might not be a constant
SHIFT_HZ might not be a constant
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-26 03:42 EST by Florian La Roche
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-28 08:41:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian La Roche 2003-10-26 03:42:02 EST
Description of problem:

/usr/include/linux/timex.h tries to setup SHIFT_HZ which is also
needed for a recompile of ntp rpm. This fails with the current sources.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Harald Hoyer 2003-10-27 06:40:54 EST
SHIFT_HZ is not used by ntp!!!
Comment 2 Arjan van de Ven 2003-10-27 09:50:52 EST
anything that uses HZ is broken; it needs to use the sysconf value since it can
vary at runtime... (eg ia64 has 1024 as userspace visible HZ, x86 100 etc etc)
Comment 3 Florian La Roche 2003-10-27 10:01:18 EST
The current glibc-kernheaders are not working and a recompile of ntp fails.
If ntp does not need SHIFT_HZ, then maybe deleting those lines is the best
solution?

greetings,

Florian La Roche
Comment 4 Harald Hoyer 2003-10-27 10:14:37 EST
In file included from ntp_loopfilter.c:1040:
/usr/include/linux/timex.h:63:5: missing binary operator before token "("
/usr/include/linux/timex.h:65:7: missing binary operator before token "("
/usr/include/linux/timex.h:67:7: missing binary operator before token "("
/usr/include/linux/timex.h:69:7: missing binary operator before token "("
/usr/include/linux/timex.h:71:7: missing binary operator before token "("
/usr/include/linux/timex.h:73:7: missing binary operator before token "("
/usr/include/linux/timex.h:75:7: missing binary operator before token "("
/usr/include/linux/timex.h:78:3: #error You lose.
Comment 5 Harald Hoyer 2003-10-27 10:18:06 EST
well... I need MAXFREQ NTP_PHASE_LIMIT NEW_MAXTC MAXPHASE to limit the
parameters for adjtimex()
Comment 6 Harald Hoyer 2003-10-27 10:23:48 EST
should be fixed with ntp-4.2.0, when it's through beehive

Note You need to log in before you can comment on or make changes to this bug.