This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 108034 - Wrong info about memory and swap utilization with kernel 2.6
Wrong info about memory and swap utilization with kernel 2.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-system-monitor (Show other bugs)
rawhide
athlon Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-26 15:04 EST by Marcin Zajaczkowski
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: libgtop2-2.5.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-01 02:51:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of misread memory size (106.28 KB, text/plain)
2004-02-14 15:28 EST, Alexander Farley
no flags Details
fixed screenshot (106.28 KB, image/png)
2004-02-14 15:30 EST, Alexander Farley
no flags Details

  None (edit)
Description Marcin Zajaczkowski 2003-10-26 15:04:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pl-PL; rv:1.5b) Gecko/20030827

Description of problem:
After change kernel from 2.4.23-pre6 to 2.6-test8 in System Monitor info about
memory & swap utilization is wrong. I see that it is used 0 bytes of 4K of
memory and 0 bytes of 11K of swap (second values change sametimes).
I think Top's report is correct. Maybe problem is not in System Monitor but in
LibGTop?

Version-Release number of selected component (if applicable):
gnome-system-monitor-2.4.0-1

How reproducible:
Always

Steps to Reproduce:
1.Run Linux with 2.6-test8 kernel
2.Open System Monitor
3.Look at memory & swap utilization
    

Additional info:
Comment 1 Alexander Farley 2004-02-14 15:28:45 EST
Created attachment 97674 [details]
screenshot of misread memory size

I am also seeing this problem with FC2-test1.
Comment 2 Alexander Farley 2004-02-14 15:30:40 EST
Created attachment 97675 [details]
fixed screenshot
Comment 3 Marcin Zajaczkowski 2004-02-15 06:13:17 EST
After your report I had changed bug qualification from system-monitor
to libgtop (at gnome Bugzilla
(http://bugzilla.gnome.org/show_bug.cgi?id=134422)) and I got reply
http://bugzilla.gnome.org/show_bug.cgi?id=129863 .

Does FC2-test1 contain actual version of libgtop? Try to upgrade (if
accessible) and if everything goes ok mark bugs as RESOLVED.
Comment 4 Thomas Covello 2004-02-15 12:10:21 EST
Sorry for the bugspam... adding myself to cc list
Comment 5 Brian Krahmer 2004-02-29 02:14:42 EST
I'm running FC2-test1, and am seeing the same problem.

gnome-system-monitor-2.5.2-2
libgtop-1.0.12-20
Comment 6 Marcin Zajaczkowski 2004-02-29 04:32:15 EST
What libgtop2 version do You have? libgtop2-2.5.1-1 ? If not try to
upgrade to FC development version (e.g. from
ftp://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/libgtop2-2.5.1-1.i386.rpm
People from Gnome said that this problem was solved and shouldn't
exist in libgtop2 versions released after January (but in FC2-test1 is
file created on 26 January which can be too old).
Comment 7 Brian Krahmer 2004-02-29 19:50:23 EST
I updated today, and the problem is indeed fixed now.

gnome-system-monitor-2.5.3-1
libgtop2-2.5.1-1

thanks!
Comment 8 Marcin Zajaczkowski 2004-03-01 02:51:28 EST
I think I can mark this bug as RESOLVED (of course if I had needed
privileges :) ).

To the next bug ;)

Note You need to log in before you can comment on or make changes to this bug.