Bug 108037 - Plugging in Wacom tablet keeps all USB from being detected
Summary: Plugging in Wacom tablet keeps all USB from being detected
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rhgb   
(Show other bugs)
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-26 20:18 UTC by J. J. Ramsey
Modified: 2007-11-30 22:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-13 16:12:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config file for serial mouse (3.11 KB, text/plain)
2003-10-26 22:42 UTC, J. J. Ramsey
no flags Details
XF86Config file for Wacom tablet (4.73 KB, text/plain)
2003-10-26 22:43 UTC, J. J. Ramsey
no flags Details
XF86Config file for Wacom tablet (reworked) (4.01 KB, text/plain)
2003-10-27 02:30 UTC, J. J. Ramsey
no flags Details

Description J. J. Ramsey 2003-10-26 20:18:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:

If I plug in a USB Wacom Graphire tablet, it intially gets powered up and
appears in the output of "lsusb" as well as all my other USB device, a scanner.
Both the "scanner" and "wacom" kernel modules are loaded. After a reboot, no USB
device is detected at all; lsusb produces no output, and /proc/bus/usb is an
empty file. The "scanner" module is not loaded; however, the "wacom" kernel
module is loaded. When the Graphire is detached and the system rebooted,
everything is back to normal.


Version-Release number of selected component (if applicable):
hotplug-2003_08_05-1

How reproducible:
Always

Comment 1 J. J. Ramsey 2003-10-26 22:42:56 UTC
Created attachment 95494 [details]
XF86Config file for serial mouse

Comment 2 J. J. Ramsey 2003-10-26 22:43:40 UTC
Created attachment 95495 [details]
XF86Config file for Wacom tablet

Comment 3 J. J. Ramsey 2003-10-26 22:53:40 UTC
Ok, more info.

Here's what I needed to do to make Fedora 0.95 work with my Wacom Graphire.

1. Boot Fedora without the Graphire, with my serial mouse, and with the
XF86Config file for my serial mouse (attached).

2. Plug in my Graphire. The LED that indicates that it is powered on lights up.

3. Replace the XF86Config file for my serial mouse with the XF86Config file for
my Wacom tablet (attached).

4. Restart X. At this point everything pretty much works, except that the mouse
cursor is initially frozen and I have to touch the stylus to the tablet to
unfreeze it.

Once I reboot, it all goes to pieces. The LED on my tablet won't light up, 
lsusb produces no output, etc.


Comment 4 Bill Nottingham 2003-10-27 01:37:05 UTC
This sounds more like a kernel problem.

Comment 5 J. J. Ramsey 2003-10-27 02:30:20 UTC
Created attachment 95500 [details]
XF86Config file for Wacom tablet (reworked)

This is a variant of the original "XF86Config file for Wacom tablet." I got rid
of the hack where I set the CorePointer to a bogus InputDevice, and instead
used the Graphire mouse as the CorePointer. Unfortunately, it made no
difference. All the same symptoms as before.

Comment 6 J. J. Ramsey 2003-10-28 01:13:33 UTC
The problem was with the kernel on the Fedora test3 CDs.
kernel-2.4.22-1.2108.nptl seems to work fine.


Comment 7 J. J. Ramsey 2003-10-31 19:51:28 UTC
The bug was neither in the kernel nor hotplug, but in rhgb. The reason I didn't
notice this before was that when I upgraded from test3 to Rawhide, the init
scripts also changed such that the graphical boot never ran. (See the thread
"ok, graphical boot, one more time," esp.
http://www.redhat.com/archives/fedora-test-list/2003-October/msg04131.html) When
I reenabled rhgb, however, the problem with my Graphire returned, and when I
disabled it, the problem went away.


Comment 8 Warren Togami 2004-03-07 09:23:20 UTC
I would agree this totally does not sound like a rhgb, but rather
kernel problem.

Is this still an issue with FC1 with the latest official kernel update
and XFree86-4.3.0-55?

What about FC2test1 plus all rawhide updates?

Comment 9 Warren Togami 2004-03-07 09:43:44 UTC
Possibly possibly if your issue really is isolated to rhgb, please see
if the behavior described in Bug #109294 matches your problem.

Comment 10 J. J. Ramsey 2004-03-07 18:23:45 UTC
> Possibly possibly if your issue really is isolated to rhgb, please see
> if the behavior described in Bug #109294 matches your problem.

It's similar, but it doesn't quite match. In bug #109294, the mouse
moves eventually, but in my case, the Graphire's mouse never moves.

BTW, in the non-graphical boot, the LED on my Graphire (which
indicates that it's powered up) doesn't light up until the boot
message "Checking module dependencies" comes up. With rhgb running,
the LED *never* lights up.


Comment 11 Kristian Høgsberg 2004-09-13 14:03:33 UTC
I just tried booting the latest rawhide with a wacom tablet and a usb
serial port (didn't have a scanner) plugged in.  I couldn't reproduce
the problem; both the wacom tablet and the serial port show up in
lsusb and they both work.  I did boot with rhgb.  The tablet LED
lights up when the USB hci module is loaded in /etc/rc.d/rc.sysinit.


Comment 12 Daniel Veillard 2004-09-13 16:12:08 UTC
Okay, so this seems fixed now,

  thanks !

Daniel


Note You need to log in before you can comment on or make changes to this bug.