Bug 108049 - %makeinstall should use %__make for make
Summary: %makeinstall should use %__make for make
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-rpm-config   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-27 02:55 UTC by Jens Petersen
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-03 20:35:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trivial patch to use __make instead (468 bytes, patch)
2003-10-27 03:01 UTC, Jens Petersen
no flags Details | Diff

Description Jens Petersen 2003-10-27 02:55:24 UTC
Description of problem:
I think it would be more consistent if %makeinstall was defined to use
%{__make} instead of make.  Could this please be done?

Comment 1 Jens Petersen 2003-10-27 03:01:38 UTC
Created attachment 95501 [details]
trivial patch to use __make instead

Comment 2 Jeff Johnson 2003-10-27 17:37:25 UTC
Consistent, yes. Worth the effort? Hardly.

Comment 3 Jens Petersen 2003-10-28 13:47:30 UTC
It is a trivial patch, where is the effort?
I need this for building emacs on i386 currently...

Comment 4 Jeff Johnson 2003-10-30 12:32:32 UTC
Yes, it's a trivial patch, but a huge QA effort to verify
nothing broke by rebuilding everything.

There's nothing forcing you to use %makeinstall,
nor is there any reason that you cannot attempt
redefinition in your xemacs spec file.

Nor is there anything stopping you from changing
%makeinstall in redhat-rpm-config 

Comment 5 Jens Petersen 2003-10-31 06:12:49 UTC
Fair'nuf, shooting for redhat-rpm-config instead then.

Comment 6 Jens Petersen 2003-10-31 06:43:44 UTC
Elliot, if you're ok with this (for the next release),
can I go ahead and make this change, or do you want to do it?

Comment 7 Elliot Lee 2003-11-03 20:35:31 UTC
This is fixed in 

The comments about needing this for emacs worry me though. It
shouldn't be necessary to redefine __make except in very strange
circumstances.

Comment 8 Jens Petersen 2003-11-04 05:34:14 UTC
Because I need "__make" to be "setarch i386" to build emacs
on ix86 currently... (bug 101818).

Comment 9 Jens Petersen 2003-11-04 05:34:48 UTC
"setarch i386 make" that is.


Note You need to log in before you can comment on or make changes to this bug.