Bug 108069 - mharris's pine source rpm won't build on fedora
mharris's pine source rpm won't build on fedora
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: pine (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 08:01 EST by Michael Young
Modified: 2007-04-18 12:58 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.58-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-27 20:16:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2003-10-27 08:01:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4) Gecko/20031016

Description of problem:
The pine source rpm available from ftp://people.redhat.com/mharris/pine
won't just work(TM) when rebuilt on fedora, because it looks for the kerberos
library files in the wrong place. The library files are now in the main library
directory /usr/lib rather than /usr/kerberos/lib. One workaround is to create
symbolic links in /usr/kerberos/lib before building the rpm. Note this is with
krb5-libs version 1.3.1-6.
Comment 1 Satish Balay 2003-10-27 10:19:28 EST
The following modification to the pine.spec (at line 128) should get it working.

%{?!nokerberos: rm -f krb5 && mkdir krb5 && ln -s /usr/include krb5/include &&
ln -s /usr/lib krb5/lib}
Comment 2 Mike A. Harris 2003-10-27 10:39:00 EST
I've already fixed it using the proper mechanism of calling:
    krb5-config --prefix
and
    krb5-config --includes

in the appropriate places, will be in pine-4.58-2 soon, which will be
available under mharris/fedora-extras somewhere, I haven't solidified
on a particular directory structure yet tho  ;o)
Comment 3 Michael Young 2003-10-27 11:04:04 EST
Note. The new pine-4.58-2 is currently available via
ftp://people.redhat.com/mharris/testing/unstable/
Comment 4 Mike A. Harris 2003-10-27 20:16:34 EST
Yup, fixed now...  not in rawhide though... hmm...  what resolution to choose...
;o)

I guess overloading the CURRENTRELEASE resolution is about the closest I can
choose..  ;o)

Closing as fixed in CURRENTRELEASE 4.58-2 at:

    ftp://people.redhat.com/mharris/testing/unstable/

Note You need to log in before you can comment on or make changes to this bug.