Bug 108085 - up2date "crashes" with key error when trying to get obsoletes list
up2date "crashes" with key error when trying to get obsoletes list
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 108086 108116 108169 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 10:06 EST by Richard Torkar
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 22:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Torkar 2003-10-27 10:06:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031023
Epiphany/1.0.1

Description of problem:
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1365, in onChannelsPageNext
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 123, in run
    progressCallback = self.progressCallback )
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 404, in obsoletesList
    progressCallback = progressCallback )
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 110, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 27, in getObsoletes
    return self.handlers[channel['type']].getObsoletes(channel, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 249, in getObsoletes
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 293, in
getObsoletes
    pkgList = self.pkglists[channel['label']]
KeyError: rawhide
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1431, in onSkippedPagePrepare
    self.__preparePackageList()
  File "/usr/share/rhn/up2date_client/gui.py", line 1317, in __preparePackageList
    self.pList.run()
  File "/usr/share/rhn/up2date_client/packageList.py", line 123, in run
    progressCallback = self.progressCallback )
  File "/usr/share/rhn/up2date_client/rhnPackageInfo.py", line 404, in obsoletesList
    progressCallback = progressCallback )
  File "/usr/share/rhn/up2date_client/rpcServer.py", line 110, in doCall
    ret = apply(method, args, kwargs)
  File "/usr/share/rhn/up2date_client/repoDirector.py", line 27, in getObsoletes
    return self.handlers[channel['type']].getObsoletes(channel, msgCallback,
progressCallback)
  File "/usr/share/rhn/up2date_client/rpmSource.py", line 249, in getObsoletes
    msgCallback, progressCallback)
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 293, in
getObsoletes
    pkgList = self.pkglists[channel['label']]
KeyError: rawhide


Version-Release number of selected component (if applicable):
up2date-4.1.11-3

How reproducible:
Always

Steps to Reproduce:
Run up2date-4.1.11-3 and click forward twice...
Comment 1 Richard Torkar 2003-10-27 10:22:10 EST
I did rm -f /var/spool/up2date/* and now it works...
Comment 2 Paul Nasrat 2003-10-27 10:34:55 EST
Hmm, ok sounds like something that Adrian mentioned.  I believe rm -f
/var/spool/up2date/rawhide* should be sufficient.
Comment 3 Gene Czarcinski 2003-10-27 11:22:52 EST
*** Bug 108086 has been marked as a duplicate of this bug. ***
Comment 4 Adrian Likins 2003-10-27 12:25:47 EST
yeah, blowing away the package list and/or all of /var/spool/up2date/ should
work.

or grab 4.1.12 when it hits the wire, it's handles that exception better
Comment 5 Bill Nottingham 2003-10-28 10:46:52 EST
*** Bug 108169 has been marked as a duplicate of this bug. ***
Comment 6 Miloslav Trmac 2004-03-01 04:20:31 EST
*** Bug 108116 has been marked as a duplicate of this bug. ***
Comment 7 Barry K. Nathan 2004-07-14 11:37:57 EDT
Should this bug still be open? 4.1.12 seemed to fix this in my
experience...
Comment 8 Todd Warner 2004-08-26 22:00:50 EDT
closed

Note You need to log in before you can comment on or make changes to this bug.