Bug 108086 - up2date (gui) hangs "Fetching obsoletes list"
Summary: up2date (gui) hangs "Fetching obsoletes list"
Status: CLOSED DUPLICATE of bug 108085
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-27 15:10 UTC by Gene Czarcinski
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gene Czarcinski 2003-10-27 15:10:06 UTC
Description of problem:
After updating to (only) up2date 4.1.11-1, I tried running it a second time to
get the rest of the updates ... it hung "Fetching obsoletes list from http://...

Comment 1 Gene Czarcinski 2003-10-27 15:14:56 UTC
running up2date-nox -i patch I get:

Fetching Obsoletes list for channel: rawhide...
  
Fetching obsoletes list for http://ftp.redhat.com/pub/redhat/linux/rawhide/...
Traceback (most recent call last):
  File "/usr/sbin/up2date-nox", line 1187, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date-nox", line 765, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date-nox", line 1050, in batchRun
    batch.run()
  File "up2dateBatch.py", line 58, in run
  File "up2dateBatch.py", line 96, in __findPackagesToUpdate
  File "packageList.py", line 123, in run
  File "rhnPackageInfo.py", line 404, in obsoletesList
  File "rpcServer.py", line 110, in doCall
  File "repoDirector.py", line 27, in getObsoletes
  File "rpmSource.py", line 249, in getObsoletes
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 293, in
getObsoletes
    pkgList = self.pkglists[channel['label']]
KeyError: rawhide

Comment 2 Gene Czarcinski 2003-10-27 16:22:50 UTC
108085 files while I was filling this out

*** This bug has been marked as a duplicate of 108085 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:59:27 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.