This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 108116 - up2date fails up2dating itself
up2date fails up2dating itself
Status: CLOSED DUPLICATE of bug 108085
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-27 13:58 EST by Chris Ricker
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-10-27 13:58:42 EST
I can't tell if this is a known bug or not...

When I up2dated (up2date --nox -u) it finished by saying

New Up2date available

When I then tried to up2date up2date, it tracebacked:

[kaboom@skuld kaboom]$ sudo up2date --nox up2date

Fetching package list for channel: rawhide...

Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
########################################

Fetching Obsoletes list for channel: rawhide...

Fetching obsoletes list for http://ftp.redhat.com/pub/redhat/linux/rawhide/...
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1187, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 765, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1050, in batchRun
    batch.run()
  File "up2dateBatch.py", line 58, in run
  File "up2dateBatch.py", line 96, in __findPackagesToUpdate
  File "packageList.py", line 123, in run
  File "rhnPackageInfo.py", line 404, in obsoletesList
  File "rpcServer.py", line 110, in doCall
  File "repoDirector.py", line 27, in getObsoletes
  File "rpmSource.py", line 249, in getObsoletes
  File "/usr/share/rhn/up2date_client/repoBackends/yumRepo.py", line 293, in
getObsoletes
    pkgList = self.pkglists[channel['label']]
KeyError: rawhide
[kaboom@skuld kaboom]$

This is with 4.1.11-3 on a up2dated test3 / rawhide box
Comment 1 Chris Ricker 2003-10-27 14:03:52 EST
After clean up, it works:

[kaboom@skuld kaboom]$ sudo rm /var/spool/up2date/*
[kaboom@skuld kaboom]$ sudo up2date --nox up2date

Fetching package list for channel: rawhide...

Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
########################################
#######################################
Fetching Obsoletes list for channel: rawhide...

Fetching obsoletes list for http://ftp.redhat.com/pub/redhat/linux/rawhide/...
#######################################
Fetching rpm headers...

Name                                    Version        Rel     
----------------------------------------------------------


The following packages you requested are already updated:
up2date
[kaboom@skuld kaboom]$ 

But it tells me up2date is already up-to-date, so now I'm confused why it ever
told me new up2date available in the first place....
Comment 2 Michael Young 2003-10-27 17:26:21 EST
Duplicate of bug 108085.
Comment 3 Miloslav Trmac 2004-03-01 04:20:29 EST

*** This bug has been marked as a duplicate of 108085 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:59:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.