Bug 108157 - /usr/lib64/sa/sa1 uses /usr/lib, cron floods root mail
/usr/lib64/sa/sa1 uses /usr/lib, cron floods root mail
Status: CLOSED DUPLICATE of bug 82913
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysstat (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Charlie Bennett
Brian Brock
:
Depends On:
Blocks: 106712
  Show dependency treegraph
 
Reported: 2003-10-27 23:50 EST by Pete Zaitcev
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /etc/cron.d/sysstat (402 bytes, patch)
2004-02-17 05:39 EST, Tsai Li Ming
no flags Details | Diff
Patch for sysstat.spec (293 bytes, patch)
2004-02-17 05:47 EST, Tsai Li Ming
no flags Details | Diff

  None (edit)
Description Pete Zaitcev 2003-10-27 23:50:22 EST
Description of problem:

/usr/lib64/sa/sa1 refers to ENDIR=/usr/lib/sa, which is missing.

Version-Release number of selected component (if applicable):

sysstat-4.0.7-3

How reproducible:

Always

Steps to Reproduce:
1. install sysstat on an s390x system.
2.
3.
    
Actual results:


Expected results:


Additional info:

This produces a flood of the following messages from cron:

/usr/lib64/sa/sa1: line 9: cd: /usr/lib/sa: No such file or directory
/usr/lib64/sa/sa1: line 14: /usr/lib/sa/sadc: No such file or directory
/usr/lib64/sa/sa1: line 14: exec: /usr/lib/sa/sadc: cannot execute: No such file
or directory
Comment 1 Zenon Panoussis 2003-11-14 09:19:16 EST
The same, but the other way around, happens on i386;
/etc/crontab/systat keeps looking for /usr/lib64/sa/sa1 every 10
minutes, but there is no /usr/lib64 directory to begin with.
Repointing to /usr/lib/sa/sa1 fixes the problem. 
Comment 2 donavan nelson 2003-11-19 15:03:20 EST
The bug is actually located in /etc/cron.d/sysstat
Comment 3 Karsten Hopp 2003-11-25 05:48:17 EST
fixed in sysstat-4.0.7-4, see bug #82913 

*** This bug has been marked as a duplicate of 82913 ***
Comment 4 Tsai Li Ming 2004-02-17 05:39:09 EST
Created attachment 97734 [details]
Patch for /etc/cron.d/sysstat

Fixes /etc/cron.d/sysstat. Change to /usr/lib/sa/sa1 1 1
Comment 5 Tsai Li Ming 2004-02-17 05:43:12 EST
Comment on attachment 97734 [details]
Patch for /etc/cron.d/sysstat

It's not fixed in 4.0.7-4 and there's no newer release for RHEL WS 3.
Comment 6 Tsai Li Ming 2004-02-17 05:47:23 EST
Created attachment 97735 [details]
Patch for sysstat.spec

Additional patch is required for sysstat.spec to detect ia64 arch.
Comment 7 Red Hat Bugzilla 2006-02-21 13:59:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.