Bug 10816 - Kickstart instalation fail with --onpart
Kickstart instalation fail with --onpart
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-14 08:01 EDT by malcolm
Modified: 2008-05-01 11:37 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-14 14:55:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixes from jorit against 6.2 installer to fix problem (3.83 KB, patch)
2000-04-25 15:07 EDT, Michael Fulbright
no flags Details | Diff

  None (edit)
Description malcolm 2000-04-14 08:01:51 EDT
When performing a kickstart instalation on cdrom an "Exeption Occurred"
message shows up.
This happends if one is trying to use the --onpart argument por the "part"
clause. Without this clause the instalation proceeds ok, but this option
is needed in order to automate instalation on machines with several disks
where partitions are already created and which situation is relevant for
performance.
The "part" clause was tried the following way,

part / --onpart hda1

Other ways where tried, which are

part / --size 1000 --onpart hda1 --ondisk hda
part / --size 1000 --onpart /dev/hda1
part / --size 1000 --onpart /dev/hda1 --ondisk hda

The Traceback (inermost last) seems to finally point to line 395 on
/usr/lib/anaconda/todo.py, saying "AttributeError: mounts".

This error has been tested on several machines with different HW setups
with the same results.
Comment 1 Jay Turner 2000-04-17 15:58:59 EDT
Issue has been forwarded to a developer for further action.
Comment 2 Anonymous 2000-04-22 11:52:59 EDT
The problem seems to be that there is an old addMount in todo.py and that the
fstab attribute in class todo is None at the addition point in todo.py.
The problem is urgent for us because we need to set up 70 boxes of Red Hat Linux
and Windows 2000 for our computer lab at the university of Stuttgart so we can't
do repartition every installation.
Comment 3 Michael Fulbright 2000-04-25 12:11:59 EDT
Does the partition exist before doing the install?
Comment 4 Michael Fulbright 2000-04-25 12:24:59 EDT
Problem verified, will be looking into a solution.
Comment 5 Michael Fulbright 2000-04-25 15:07:59 EDT
Created attachment 212 [details]
Fixes from jorit against 6.2 installer to fix problem
Comment 6 Anonymous 2000-04-27 13:56:59 EDT
Tried the patch and it shows up the DiskDruid/fdisk dialog, so having to enter
one partition location which makes it crash after formating with a "device busy"
message. In the oder hand if you leave one partition unallocated and just
allocate this one with diskdruid all other partitions specified on kickstart are
used by anaconda succesfully.
	onpart + swap does not work
Comment 7 Michael Fulbright 2000-04-27 15:24:59 EDT
The patch was based on the files you sent me - are you saying that your
original source fixed the problem and that when you use the patch I created
that it no longer works?  That would indicate my patch is faulty if so.
Comment 8 Anonymous 2000-04-28 06:09:59 EDT
I never sent you any sources, I have used the code from the redhat 6.2 instaler
and merged them with the patch that you posted. Once the patch was merged hte
installation half worked (before never did), showing the errors that I said on
my last comment (diskdruid shows when it was not to, swap does not work with
--onpart). Doing more testing I found that raid does not work as well with
--onpart an error raises within the installation on installclass.py saying "raid
device not found". I have used the same sintax for raid that comes in the
sample.ks file.
At the moment the swap+onpart error is not very important for me as I can add it
on the postinstal section of the kickstart, while raid problem is catastrofic,
because when doing it on the postinstal for mountpoints like /var I loosse
important links.
If you mean that you have different sources than the RH 6.2 installer and that
them work with your patch (almost raid), please mail them to me so I can test
them.
Comment 9 Jorit Dorn 2000-05-01 04:52:59 EDT
One thing Micheal left out was our patch to skip the partition winodws.
You just have to add these commands at the end of ks.cfg. We don't think
that the skip list call is at the right place because it's unconditional,
but we made it there because we know our configuration. Micheal has to figure
out the right posistion for the next release (7.0?).

It works fine for us and it is tested on 70 (identical) machines but we don't
use raid (with one disk that doesn't make sense :-)

Maybe this small patch fixes the loss of partition data.

patch: /RedHat/instimage/usr/lib/anaconda/kickstart.py
        self.installType = "install"
        self.readKickstart(file)

        # no partitioning windows
        # We don't think this is a good place
        # to add these commands but we didn't figure out a better
        # place -- and it works 4 us :-)
        # Jorit <joritdorn@yahoo.com>
        # Fabi  <Florian.Festi@rupert.informatik.uni-stuttgart.de>
        self.addToSkipList("partition")
        self.addToSkipList("format")
Bye Jorit
Comment 10 osi 2000-05-26 09:56:59 EDT
--onpart works for sparc installation with the patch, but Jorit's addition of

self.addToSkipList("partition")
self.addToSkipList("format")

is necessary.  If a kickstart installation is used on one of our sparcs,
--onpart is the only way around of the following problem:
1) Installing on a "foreign" disk (e.g. a disk from a i386/Linux) fails,
both in text and X mode just before selecting disk partitions.  The workaround
is to create the device (e.g. sda) with mknod and to run fdisk on that.
This, of course, is a problem only during the first installation on a disk.
2) If a kickstart installation without --onpart is tried, the largest
partition is placed first, which fails with buggy PROMS like ours: SILO
does not work with partitions > 1GB.  Thus, I had to create the partitions
by hand and use --onpart in kickstart files.

The sparcs used here are an LX and two IPX SPARCstations with 2 GB of disk.

P.S. Thank you once more for the kickstart feature, it is a must in our lab
with 50 workstations.  The new python way of doing it really helped
in debugging the problems.
Comment 11 Michael Fulbright 2000-06-12 14:57:56 EDT
Test lab - please verify latest internal version of installer fixes this bug.
Comment 12 Brock Organ 2000-07-14 14:55:20 EDT
verified fix in internal build ...
Comment 13 Marc Schmitt 2000-09-01 04:15:30 EDT
Seems I`m a bit late...

I downloaded ftp://rawhide.redhat.com/pub/rawhide/i386/images/bootnet.img, but
it does not work with RedHat 6.2 anymore, asking for netstg1.img.

Can someone provide a working bootnet.img that has just the --onpart bug fixed
and works with RedHat 6.2?

Thanks.
Comment 14 Marc Schmitt 2000-09-01 06:30:39 EDT
Sorry, please ignore/delete my posts.

Note You need to log in before you can comment on or make changes to this bug.