Bug 108162 - text install using autopartition errors or crashes when trying to "fill all available space" and partition size left blank.
text install using autopartition errors or crashes when trying to "fill all a...
Status: CLOSED DUPLICATE of bug 108164
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
: 108163 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 02:05 EST by Karsten Wade
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2003-10-28 02:05:07 EST
Description of problem:

When performing a text install and choosing autopartition, manual partition acts
in a non-intuitive way.  If you select  "Fill all available space:" and deselect
the other partition size options, an error returns:

Invalid Entry for Partition Size
Must specify a value.

One would assume that if you are selecting an option to fill the partition with
all available space, it would not be necessary to define any sizing.

As it so happens, if you put a 1 in the "Size (MB)" field, it will accept that
and go forward, creating a partition which uses all available space.  Putting in
a 0 (zero) causes anaconda to crash.  See the follow-on bug report for the
traceback.

Version-Release number of selected component (if applicable):

RHEL 3
anaconda as ships with RHEL 3
diskdruid? as ships with RHEL 3

How reproducible:
Always.

Steps to Reproduce:
1. Start a text install of RHEL 3, choose autopartitioning
2. Manually tweak the offered partition, creating a new partition which takes up
all available space
3. Set the "Size (MB)" to 0 (zero) to crash, or to nothing to cause it to error
in an unexpected fashion.
    
Actual results:
Crash or apparent inability to set a dynamic partition creating size without
specifying a static vallue.

Expected results:
Nothing crashes or complains when the "Size (MB)" filed is filled with 0 or left
blank.

Additional info:

See follow-up traceback.
Comment 1 Bill Nottingham 2003-10-28 10:43:40 EST
*** Bug 108163 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-10-28 10:44:03 EST
*** This bug has been marked as a duplicate of 108164 ***

*** This bug has been marked as a duplicate of 108164 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:28 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.