Bug 108164 - text install using autopartition errors or crashes when trying to "fill all available space" and partition size left blank.
Summary: text install using autopartition errors or crashes when trying to "fill all a...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 108162 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-28 07:11 UTC by Karsten Wade
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 02:48:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback dump (38.25 KB, text/plain)
2003-10-28 07:13 UTC, Karsten Wade
no flags Details
anaconda traceback dump (38.25 KB, text/plain)
2003-10-28 07:13 UTC, Karsten Wade
no flags Details
syslog of system for time around the anaconda crash. (6.58 KB, text/plain)
2003-10-28 07:14 UTC, Karsten Wade
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:195 normal SHIPPED_LIVE Updated anaconda and other installer related packages available 2004-05-24 04:00:00 UTC

Description Karsten Wade 2003-10-28 07:11:33 UTC
Description of problem:

When performing a text install and choosing autopartition, manual partition acts
in a non-intuitive way.  If you select  "Fill all available space:" and deselect
the other partition size options, an error returns:

Invalid Entry for Partition Size
Must specify a value.

One would assume that if you are selecting an option to fill the partition with
all available space, it would not be necessary to define any sizing.

As it so happens, if you put a 1 in the "Size (MB)" field, it will accept that
and go forward, creating a partition which uses all available space.  Putting in
a 0 (zero) causes anaconda to crash.  See the follow-on bug report for the
traceback.

Version-Release number of selected component (if applicable):

RHEL 3
anaconda as ships with RHEL 3
diskdruid? as ships with RHEL 3

How reproducible:
Always.

Steps to Reproduce:
1. Start a text install of RHEL 3, choose autopartitioning
2. Manually tweak the offered partition, creating a new partition which takes up
all available space
3. Set the "Size (MB)" to 0 (zero) to crash, or to nothing to cause it to error
in an unexpected fashion.
    
Actual results:
Crash or apparent inability to set a dynamic partition creating size without
specifying a static vallue.

Expected results:
Nothing crashes or complains when the "Size (MB)" filed is filled with 0 or left
blank.

Additional info:

See follow-up traceback.

Comment 1 Karsten Wade 2003-10-28 07:13:04 UTC
Created attachment 95540 [details]
anaconda traceback dump

This was the traceback generated when the value of 0 was entered into the "Size
(MB)" field.

Comment 2 Karsten Wade 2003-10-28 07:13:15 UTC
Created attachment 95541 [details]
anaconda traceback dump

This was the traceback generated when the value of 0 was entered into the "Size
(MB)" field.

Comment 3 Karsten Wade 2003-10-28 07:14:27 UTC
Created attachment 95542 [details]
syslog of system for time around the anaconda crash.

This was the syslog for the install session.  Going to try to submit this
without sending it twice. :/

Comment 4 Jeremy Katz 2003-10-28 15:34:37 UTC
Don't do that then :-)

Comment 5 Bill Nottingham 2003-10-28 15:44:05 UTC
*** Bug 108162 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2003-10-28 15:55:29 UTC
Fixed, thanks for the machine access.

Comment 7 Jeremy Katz 2003-11-03 04:35:23 UTC
Oops, last comment was meant for another bug.

I've actually fixed this now on HEAD of CVS.  It's a candidate to
backport for a Taroon update at some point, but it's been this way
forever, so I don't know how high of a priority it is to actually do so.

Comment 8 John Flanagan 2004-05-12 02:48:52 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-195.html



Note You need to log in before you can comment on or make changes to this bug.