Bug 108181 - Hyundai monitor not detected on Radeon 8500LE card
Hyundai monitor not detected on Radeon 8500LE card
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 08:44 EST by David Balažic
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-15 14:18:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci and lspci -vn output (5.90 KB, text/plain)
2003-10-28 08:45 EST, David Balažic
no flags Details
The rest of Xorg.0.log (42.64 KB, text/plain)
2004-06-15 03:42 EDT, David Balažic
no flags Details

  None (edit)
Description David Balažic 2003-10-28 08:44:29 EST
Description of problem:

During install ( GUI mode, from local CD ), my monitor model is not detected. In
the Monitor selection screen "Unprobed Monitor" is selected.
My monitor type is Hyundai HT-7695B.

It was correctly detected on my older gfx card ( SiS 6236 ).
My current gfx card is Hercules 3D Prophet FDX 8500LE ( Radeon 8500LE).
The older gfx card is still inserted but not used ( it is PCI, the
radeon is AGP ).

If I run ddcprobe on VT2 during install, I get :

Videocard DDC probe results
Description:  ATI Technologies Inc. R200
Memory (MB):  64

Monitor DDC probe results
ID: @A@9ba9
Width (mm): 120
Height(mm): 320

Version : Fedora Core Test 3
Comment 1 David Balažic 2003-10-28 08:45:16 EST
Created attachment 95545 [details]
lspci and lspci -vn output
Comment 2 Jeremy Katz 2003-10-28 10:43:35 EST
The monitor is giving back bogus DDC data, so we throw it out.  
Comment 3 David Balažic 2003-11-03 04:16:26 EST
What do you mean ?
It worked "perfectly" on another gfx card.

Does my radeon card mangle the DDC data ?
I am confused ...
Comment 4 David Balažic 2004-06-15 03:40:55 EDT
Same hardware, new SW ( FC2 ) , same problem, but X can detect the DDC
data without problems.

A quote from the Xorg.0.log :

(II) RADEON(0): Monitor1 EDID data ---------------------------
(II) RADEON(0): Manufacturer: HEI  Model: 769b  Serial#: 2068
(II) RADEON(0): Year: 1999  Week: 8
(II) RADEON(0): EDID Version: 1.0
(II) RADEON(0): Analog Display Input,  Input Voltage Level: 0.700/0.300 V
(II) RADEON(0): Sync:  Separate  Composite
(II) RADEON(0): Max H-Image Size [cm]: horiz.: 32  vert.: 24
(II) RADEON(0): Gamma: 2.00
(II) RADEON(0): DPMS capabilities: StandBy Suspend Off; RGB/Color Display
(II) RADEON(0): redX: 0.625 redY: 0.340   greenX: 0.285 greenY: 0.600
(II) RADEON(0): blueX: 0.150 blueY: 0.065   whiteX: 0.281 whiteY: 0.311
(II) RADEON(0): Supported VESA Video Modes:
(II) RADEON(0): 720x400@70Hz
(II) RADEON(0): 640x480@60Hz
(II) RADEON(0): 800x600@60Hz
(II) RADEON(0): 800x600@75Hz
(II) RADEON(0): 1024x768@60Hz
(II) RADEON(0): 1024x768@75Hz
(II) RADEON(0): 1280x1024@75Hz
(II) RADEON(0): Manufacturer's mask: 0
(II) RADEON(0): Supported Future Video Modes:
(II) RADEON(0): #0: hsize: 640  vsize 480  refresh: 85  vid: 22833
(II) RADEON(0): #1: hsize: 800  vsize 600  refresh: 85  vid: 22853
(II) RADEON(0): #2: hsize: 1024  vsize 768  refresh: 85  vid: 22881
(II) RADEON(0): #3: hsize: 1280  vsize 960  refresh: 60  vid: 16513
(II) RADEON(0): #4: hsize: 1280  vsize 960  refresh: 85  vid: 22913
(II) RADEON(0): #5: hsize: 1600  vsize 1200  refresh: 60  vid: 16553
(II) RADEON(0): #6: hsize: 1600  vsize 1200  refresh: 75  vid: 20393
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 55.0 MHz   Image Size:  320 x 240 mm
(II) RADEON(0): h_active: 640  h_sync: 672  h_sync_end 768 h_blank_end
864 h_border: 0
(II) RADEON(0): v_active: 480  v_sync: 488  v_sync_end 494 v_blanking:
530 v_border: 0
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 94.8 MHz   Image Size:  320 x 240 mm
(II) RADEON(0): h_active: 1024  h_sync: 1072  h_sync_end 1168
h_blank_end 1376 h_border: 0
(II) RADEON(0): v_active: 768  v_sync: 769  v_sync_end 772 v_blanking:
808 v_border: 0
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 157.5 MHz   Image Size:  320 x 240 mm
(II) RADEON(0): h_active: 1280  h_sync: 1344  h_sync_end 1504
h_blank_end 1728 h_border: 0
(II) RADEON(0): v_active: 1024  v_sync: 1025  v_sync_end 1028
v_blanking: 1072 v_border: 0
(II) RADEON(0): Supported additional Video Mode:
(II) RADEON(0): clock: 202.5 MHz   Image Size:  320 x 240 mm
(II) RADEON(0): h_active: 1600  h_sync: 1664  h_sync_end 1856
h_blank_end 2160 h_border: 0
(II) RADEON(0): v_active: 1200  v_sync: 1201  v_sync_end 1204
v_blanking: 1250 v_border: 0
(II) RADEON(0): End of Monitor1 EDID data --------------------
Comment 5 David Balažic 2004-06-15 03:42:04 EDT
Created attachment 101133 [details]
The rest of Xorg.0.log
Comment 6 Jeremy Katz 2004-06-15 14:18:33 EDT
X uses card specific i2c bits instead of the generic real-mode LRMI
interface.  And without X exporting a way to get at that (since having
that code multiple places would be bad, especially as it changes with
every bloody card), there's no way to do that and we have to use the
generic method that depends on BIOSes and other such things to not suck :)

Note You need to log in before you can comment on or make changes to this bug.