Bug 1081834 - [RFE] [cinder] Limit Bandwidth of Volume Copy
Summary: [RFE] [cinder] Limit Bandwidth of Volume Copy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Upstream M2
: 6.0 (Juno)
Assignee: Eric Harney
QA Contact: Yogev Rabl
URL: https://blueprints.launchpad.net/cind...
Whiteboard: upstream_milestone_juno-2 upstream_de...
: 1118576 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-03-28 04:07 UTC by RHOS Integration
Modified: 2018-02-08 10:14 UTC (History)
6 users (show)

Fixed In Version: openstack-cinder-2014.2-3.el7ost
Doc Type: Enhancement
Doc Text:
You can now configure the openstack-cinder-volume service to limit I/O bandwidth when copying data between volumes. This allows you to throttle the load placed on the openstack-cinder-volume node for long-running I/O copy operations. To use this feature, configure the 'volume_copy_blkio_cgroup_name' and 'volume_copy_bps_limit' settings in /etc/cinder/cinder.conf of the openstack-cinder-volume node accordingly.
Clone Of:
Environment:
Last Closed: 2015-02-09 14:58:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0151 normal SHIPPED_LIVE openstack-cinder enhancement advisory 2015-02-09 19:52:48 UTC
OpenStack gerrit 92894 None None None Never
OpenStack gerrit 97627 None None None Never
OpenStack gerrit 100642 None None None Never
OpenStack gerrit 102666 None None None Never
OpenStack gerrit 109137 None None None Never
OpenStack gerrit 109138 None None None Never

Description RHOS Integration 2014-03-28 04:07:51 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/cinder/+spec/limit-volume-copy-bandwidth.

Description:

Currently, volume copy operations consumes disk I/O bandwidth heavily and may slow down the other guest instances, during:
* new volume creation from a image
* backup
* volume deletion (when dd if=/dev/zero is chosen to wipe)
etc..
 ("ionice" option is already implemented in some cases, but it is not always usable, e.g. when instances volume access path doesn't go through I/O scheduler of cinder control node.)
 
This proposes adding conf to limit bandwidth for volume copy (or up/downloading) to mitigate interference to other instance performance.
 
For example, the limitation can be implemented by using commands' options to limit bandwidth, or putting commands (such as 'dd')  into blkio cgroup for throttling.

Specification URL (additional information):

None

Comment 1 Sean Cohen 2014-08-27 23:15:09 UTC
*** Bug 1118576 has been marked as a duplicate of this bug. ***

Comment 3 Yogev Rabl 2014-12-18 07:13:26 UTC
verified in version 
python-cinder-2014.2.1-1.el7ost.noarch
python-cinderclient-1.1.1-1.el7ost.noarch
openstack-cinder-2014.2.1-1.el7ost.noarch

Comment 6 errata-xmlrpc 2015-02-09 14:58:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0151.html


Note You need to log in before you can comment on or make changes to this bug.