Bug 108184 - PackageTool doesn't commit transaction when run with -schema
PackageTool doesn't commit transaction when run with -schema
Status: CLOSED RAWHIDE
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks: 106597
  Show dependency treegraph
 
Reported: 2003-10-28 08:55 EST by Daniel Berrange
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 11:15:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-10-28 08:55:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The JDBC connection returned by Connections.aquire has auto-commit disabled, so
explicit calls to Connection#commit are required after doing DB work. The
PackageTool never calls 'commit' when run with the '-schema' option, so the DML
work is never committed & the DB rolls it back. We are also not cleanly closing
the JDBC connection before the program exits, leading to warnings in the DB
server logs:

Oct 28 13:47:44 hillingdon postgres[12369]: [135] DEBUG:  pq_recvbuf: unexpected
EOF on client connection


NB, there seems to be something special about loading 'ccm-core' since it
doesn't exhibit this behaviour. Only ccm-cms & other apps fail with -schema.

NB, this also doesn't apply to Oracle, since it is incapable of processing a
bunch of DML statements within a transaction :-(

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run 'ccm-pkg load ccm-cms -schema'
2. Launch psql & look for cms_items table
3.
    

Actual Results:  cms_items is missing

Expected Results:  cms_items is present

Additional info:
Comment 1 Rafael H. Schloming 2003-10-28 14:42:22 EST
Fixed @37450.

Note You need to log in before you can comment on or make changes to this bug.