Bug 108201 - mutt isn't able to handle esmtp/smtp-auth
mutt isn't able to handle esmtp/smtp-auth
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mutt (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 10:57 EST by Robert Scheck
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-26 17:37:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
My esmtp src.rpm (122.81 KB, application/octet-stream)
2003-10-28 10:59 EST, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2003-10-28 10:57:16 EST
Description of problem, how reproducible and steps to Reproduce:
If I write with mutt an e-mail and send that over my local (maybe official) 
sendmail/postfix mail server and the receiver looks into the header of my 
mail, he sees among other things the following:

--- snipp ---
From localuser@localhost.localdomain  Tue Oct 28 10:02:50 2003
[...]
From: My Name <me@my-domain.tld>
[...]
--- snapp ---

The first line is caused by the problem, that mutt isn't able to handle 
esmtp/smtp-auth correct. In a *correct* mail header it should look like that:

--- snipp ---
From me@my-domain.tld  Tue Oct 28 10:02:50 2003
[...]
From: My Name <me@my-domain.tld>
[...]
--- snapp ---

Version-Release number of selected component (if applicable):
mutt-1.4.1-4

Actual results:
That problem can be solved with using esmtp (http://esmtp.sourceforge.net).

Expected results:
esmtp should be added as rpm to Fedora Core.

Additional info:
I add my own build esmtp-src.rpm to that bugzilla report - maybe the rpm can 
be added to Fedora Core?
Comment 1 Robert Scheck 2003-10-28 10:59:14 EST
Created attachment 95553 [details]
My esmtp src.rpm

This is the rpm you can use to solve that problem with mutt.
Comment 2 Bill Nottingham 2003-10-28 11:04:13 EST
I don't think we'll fix esmtp/smtp-auth problems in mutt by adding another MTA. 
Comment 3 Robert Scheck 2003-11-15 09:48:46 EST
In my opinion that's very bummer. These 50 KB more would solve the problem and it wouldn't be a tragic storage-technically problem, probably.

Another suggestion would be a patch for mutt:
http://www.deez.info/sengelha/projects/mutt/libesmtp/ - that's a patch for mutt, that gives mutt native libESMTP support. But it's still the same way to solve the problem.
Comment 4 Bill Nottingham 2005-01-26 17:37:14 EST
At this point, we aren't going to add feature patches to mutt that
aren't upstream.

Note You need to log in before you can comment on or make changes to this bug.