Bug 108208 - mtr update is necessary and there are patches for IPv6 support at mtr
Summary: mtr update is necessary and there are patches for IPv6 support at mtr
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mtr (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-28 16:34 UTC by Robert Scheck
Modified: 2015-03-05 01:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-16 10:49:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updated mtr-0.54 with well-working IPv6 support src.rpm (118.31 KB, application/octet-stream)
2003-10-28 16:36 UTC, Robert Scheck
no flags Details

Description Robert Scheck 2003-10-28 16:34:17 UTC
Description of problem:
1. mtr-0.52-3 is old - mtr-0.54 was released months ago - with a lot of fixes 
etc.
2. mtr has no IPv6 support - so I searched for patches (KAME and so on) and I 
found good working patches which should be really included.

Version-Release number of selected component (if applicable):
mtr-0.52-3

Expected results:
Updated mtr and IPv6 support at mtr.

Additional info:
I attached a actual new mtr src.rpm with working IPv6 support including the 
patches and a changed spec file. 
Please have a look to it. I would be happy, if I can find that one in 
Rawhide/Fedora Core.

Comment 1 Robert Scheck 2003-10-28 16:36:11 UTC
Created attachment 95554 [details]
Updated mtr-0.54 with well-working IPv6 support src.rpm

Here is the updated mtr-0.54 with well-working IPv6 support source rpm for
Rawhide/Fedora Core

Comment 2 Robert Thomas 2003-11-14 10:58:32 UTC
I had occasions where xmtr would hang.  I rebuilt the package using
the new .054 src from the authors site.  I have not had any hangs since.

Byte

Comment 3 Robert Scheck 2003-11-14 12:49:50 UTC
Did you try it with the version 0.54 from Rawhide/Development, too?

So when does it hang exactly? Maybe there are problems caused by my patches...

Comment 4 Daniel Roesen 2004-01-14 03:27:53 UTC
Add me to the (long) list of networking people who'd really like
to see IPv6 support in mtr...

Comment 5 Robert Scheck 2004-01-14 17:26:40 UTC
Well, the package above provides IPv6 support in mtr, if you rebuild 
it. 

But nobody of the Red Hat maintainers still wants to add it to 
Rawhide/Development :'-(

May you test it - as I do it since September 2003 - and report found 
bugs here, no one did it yet, but I don't know how many users tested 
that patched mtr...

I still think, it's important to provide IPv6 support at mtr. So 
there is IPv6 support at 'ping' and 'traceroute' already!

Comment 6 Daniel Roesen 2004-02-15 15:25:30 UTC
Phil, will we get any comment or are we just wasting our time?

Comment 7 Phil Knirsch 2004-02-16 10:49:47 UTC
I've looked at the patches today and they seem to look good to me, too.

Included them in the latest mtr-0.54-4 package which should hit
rawhide real soon.

Read ya, Phil

Comment 8 Daniel Roesen 2004-02-16 11:36:00 UTC
Thank you Phil! Appreciated!

Comment 9 Daniel Roesen 2004-02-17 21:45:22 UTC
Hm, did you push the update yet to rawhide? it didn't surface yet:

Logged in to download.fedora.redhat.com.
ncftp / > cd pub/fedora/linux/core/development/SRPMS/
Directory successfully changed.
ncftp ...core/development/SRPMS > ls -l mtr*
-rw-r--r--    1 ftp      ftp        99450   Feb  8 20:47  
mtr-0.54-2.src.rpm

Would like to start testing asap...

Comment 10 Robert Scheck 2004-02-23 17:57:39 UTC
I'm sorry to say that, but I can't find the package in the lastest 
development push (23-Feb-2004 06:31):

mtr-0.54-3.src.rpm               17-Feb-2004 00:27    97k 

"-3" was a simple rebuild, no new included patches. Could you please 
push the update to development? Thank you :)

Comment 11 Phil Knirsch 2004-03-04 15:38:23 UTC
As i've already posted to f-c-d, it must have slipped through one of
my 1001 other prio 1 things as the whole stuff has been in CVS for
quite some time.

It's in the buildsystem atm, so should really hit rawhide now today or
tomorrow.

Sorry again for the delay,

Read ya, Phil

(Just too many releases right now at the same time *sigh*).



Note You need to log in before you can comment on or make changes to this bug.