Bug 108213 - LTC5169 - ethtool -S not working with the e1000 driver
LTC5169 - ethtool -S not working with the e1000 driver
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Julie DeWandel
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 12:12 EST by Olof Johansson
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-19 14:04:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for ethtool -S <netdev> against RHEL 3 released product. (3.66 KB, patch)
2003-10-29 15:19 EST, Julie DeWandel
no flags Details | Diff
A second way to solve this problem (4.96 KB, patch)
2003-10-31 17:01 EST, Julie DeWandel
no flags Details | Diff

  None (edit)
Description Olof Johansson 2003-10-28 12:12:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3.1) Gecko/20030425

Description of problem:
p630
1 Goliad adapter

Software Environment:
RHEL3

Steps to Reproduce:
1.run ethtool -S eth1

Actual Results:
it will return:
Operation not supported.

Expected Results:
Should give all the Intel Gigabit adapter statistis. The e1000 driver supports
it, the problem is withShould give all the Intel Gigabit adapter statistis. 

Ethtool needs to get updated to support "-S" for the e1000 driver.

The problem in SLES8 was that both ETHTOOL_GSTRINGS and ETHTOOL_GSTATS were not
mapped by arch/ppc64/kernel/ioctl32.c::ethtool_ioctl()

They need to check these on RedHat.

------- Additional Comment #4 From Olof Johansson 2003-10-28 12:11 -------

This has been fixed in ameslab BK, so RedHat can pick it up from there. I'll
open up a mirror bug.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
See above  

Additional info:
Comment 1 Julie DeWandel 2003-10-29 15:15:55 EST
I will attach a proposed patch to the RHEL 3 sources to correct this problem. If
you guys (IBM) get a chance to test it, it would be appreciated. I have verified
it here.
Comment 2 Julie DeWandel 2003-10-29 15:19:40 EST
Created attachment 95588 [details]
Patch for ethtool -S <netdev> against RHEL 3 released product.

The problem was only a problem for ethtool compiled as a 32-bit application.
Worked fine as a 64-bit app.
Comment 3 Olof Johansson 2003-10-30 21:23:46 EST
------- Additional Comments From olof@us.ibm.com  2003-30-10 21:21 -------
Rick, can you test the patch RH provided? They have modified the ioctl layers,
so the BK patch doesn't apply to their tree.
Comment 4 Olof Johansson 2003-10-30 21:40:09 EST
------- Additional Comments From olof@us.ibm.com  2003-30-10 21:21 -------
Rick, can you test the patch RH provided? They have modified the ioctl layers,
so the BK patch doesn't apply to their tree.
Comment 5 Olof Johansson 2003-10-31 14:53:17 EST
ricardoz@us.ibm.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |FIXEDAWAITINGTEST
         Resolution|                            |FIX_BY_DISTRO




------- Additional Comments From ricardoz@us.ibm.com  2003-31-10 13:07 -------
I just tested the patch and it works now. Defect has been fixed.
Comment 6 Olof Johansson 2003-10-31 14:53:43 EST
------- Additional Comments From ricardoz@us.ibm.com  2003-31-10 13:09 -------
When would we expect this patch to be in the RHEL3 distro. ?
Comment 7 Julie DeWandel 2003-10-31 15:06:12 EST
Thank you for testing this patch. A suggestion was made from a kernel team
member for an improved version which I'd like to explore. My plan is to try the
second version and post it to here if all goes well. Either way, I expect this
issue to be resolved within the coming week.

But to answer your question, this problem will be fixed in Update 1 for RHEL 3.
Comment 8 Julie DeWandel 2003-10-31 17:01:19 EST
Created attachment 95637 [details]
A second way to solve this problem

This patch creates a much simpler ethtool_ioctl interface for 32-bit apps. All
ioctl commands are supported this way (both now and with future drivers). This
code borrow heavily from the 2.5 code. A patch review by IBM would be
appreciated as would testing of this patch. It has been tested here and appears
to work, but futher verification is always nice.
Comment 9 Olof Johansson 2003-10-31 17:42:55 EST
------- Additional Comments From olof@us.ibm.com  2003-31-10 17:44 -------
Julie, appropriate review method would be to post on linuxppc64-dev. Thanks.
Comment 10 Julie DeWandel 2003-11-06 09:45:55 EST
The second patch was submitted on 05-OCT-03 and should appear in Update 1.
Comment 11 Julie DeWandel 2004-01-19 14:04:35 EST
Closing on our side after verifying with IBM.

Note You need to log in before you can comment on or make changes to this bug.