Bug 108259 - DomainObjectTraversalParameterRecord doesn't work with package tool
DomainObjectTraversalParameterRecord doesn't work with package tool
Status: CLOSED WONTFIX
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-28 14:14 EST by Daniel Berrange
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-06 05:11:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-10-28 14:14:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
The com.arsdigita.domain.installer.DomainObjectTraversalParameterRecord doesn't
work with package tool. For example, with forums, it throws the following error:

Exception in thread "main" com.arsdigita.runtime.ConfigError: Resource
ccm-forum/forum.properties not found; it is required
        at
com.arsdigita.runtime.RuntimeConfigLoader.load(RuntimeConfigLoader.java:61)
        at
com.arsdigita.domain.installer.DomainObjectTraversalParameterRecord.loadAdapters(DomainObjectTraversalParameterRecord.java:108)
        at com.arsdigita.forum.Initializer.init(Initializer.java:54)
        at
com.arsdigita.runtime.CompoundInitializer.init(CompoundInitializer.java:86)
        at com.arsdigita.runtime.Startup.run(Startup.java:153)
        at com.arsdigita.packaging.PackageTool.loadData(PackageTool.java:281)
        at com.arsdigita.packaging.PackageTool.main(PackageTool.java:188)
cannot run ccm-pkg load ccm-forum -data: 256 at ./ccm-bundle.pl line 66.





Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to run com.arsdigita.forum.Initializer
2.
3.
    

Actual Results:  The above error is thrown

Additional info:

I need a solution for this use case ASAP (ie today), since a large number of
APLAWS apps use this class & I am unable to even get an APLAWS server
operational until I can load all the apps using the package tool.
Comment 1 Vadim Nasardinov 2003-10-28 14:35:24 EST
As a quick workaround, just get the server running, can you
add all the relevant directories to the classpath by appending
them to $CCM_DEV_HOME/ccm.classpath or some such?
Comment 2 Daniel Berrange 2003-11-06 05:11:33 EST
Marking this resolved, since DOTParameterRecord was just deleted &
replaced with a new coding pattern.

Note You need to log in before you can comment on or make changes to this bug.