Bug 10826 - Bad Apache configuration after run linuxconf
Summary: Bad Apache configuration after run linuxconf
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
: 11589 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-14 19:40 UTC by awhansen
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 12:31:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description awhansen 2000-04-14 19:40:14 UTC
When I change with linuxconf the server name from the Apache configuration,
apache not runs anymore, because the server name it puts is incorrect.
And linuxconf puts in the httpd.conf file a line like "PerlHandler ..."
that apache reports as an configuration error.

Comment 1 Anonymous 2000-04-24 12:31:59 UTC
I found that several <Directory> entries get fouled up as well, with an extra
double quotes appearing.

Also, the default <Files> entry included makes it impossible to get the
default "welcome" page (http://yourhostname/) even from the same machine.  This
is easy to fix, but could dissuade a Linux Newbie, and is probably a bit
overrestrictive...

Comment 2 Nalin Dahyabhai 2000-09-12 18:58:05 UTC
Linuxconf has been known to destroy known-good Apache configurations.  We're
disabling the module until it can be debugged.

Comment 3 Nalin Dahyabhai 2000-09-12 19:13:52 UTC
*** Bug 11589 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.