Bug 10839 - NIS ypserv is not setupable with RH6.2
Summary: NIS ypserv is not setupable with RH6.2
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ypserv
Version: 6.2
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-15 18:17 UTC by andreas
Modified: 2008-05-01 15:37 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2000-05-19 12:02:17 UTC


Attachments (Terms of Use)

Description andreas 2000-04-15 18:17:56 UTC
[root@gatekeeper /root]# rpm -q ypserv
ypserv-1.3.9-3

Running /usr/lib/yp/ypinit -m and not entering additional slave servers
generates the following error:

Building /var/yp/zwax/ypservers...
Running /var/yp/Makefile...
gmake[1]: Entering directory `/root'
gmake[1]: ../Makefile: No such file or directory
gmake[1]: *** No rule to make target `../Makefile'.  Stop.
gmake[1]: Leaving directory `/root'
make: *** [target] Error 2
Error running Makefile.
Please try it by hand.

/var/yp/Makefile seems to be broken:
-) it does reference a ../Makefile while there is only one Makefile in
   ypserv.
   [root@gatekeeper /root]# rpm -ql ypserv | grep -i makefile
   /var/yp/Makefile
-) It does not contain a all target, which it seems to reference. All
   available documentation seems to reference all: too, as the target
   where the available maps are configured.

Andreas

Comment 1 Florian La Roche 2000-05-19 12:02:59 UTC
maybe no domainname was set?

Comment 2 andreas 2000-05-19 13:31:59 UTC
Well, at least for me, it seems that some Makefiles are missing.

[andreas@speedy hko]$ ssh root@gate
Last login: Fri May 19 15:26:00 2000 from speedy.zwax.mtg.co.at
You have mail.
[root@gatekeeper /root]# grep domain /etc/yp.conf
#domain NISDOMAIN server HOSTNAME
#       Use server HOSTNAME for the domain NISDOMAIN.
#domain NISDOMAIN broadcast
#       Use  broadcast  on  the local net for domain NISDOMAIN
#       Use server HOSTNAME for the  local  domain.  The
domain zwax
[root@gatekeeper /root]# cd /var/yp/
[root@gatekeeper yp]# make
gmake[1]: Entering directory `/root'
gmake[1]: ../Makefile: No such file or directory
gmake[1]: *** No rule to make target `../Makefile'.  Stop.
gmake[1]: Leaving directory `/root'
make: *** [target] Error 2
[root@gatekeeper yp]# /bin/domainname zwax
[root@gatekeeper yp]# make
gmake[1]: Entering directory `/root'
gmake[1]: ../Makefile: No such file or directory
gmake[1]: *** No rule to make target `../Makefile'.  Stop.
gmake[1]: Leaving directory `/root'
make: *** [target] Error 2

Comment 3 tallen 2000-06-26 18:51:33 UTC
if I do a make i see the above problem; however, if I do a make all it's okay.


Note You need to log in before you can comment on or make changes to this bug.