Bug 10839 - NIS ypserv is not setupable with RH6.2
NIS ypserv is not setupable with RH6.2
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ypserv (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-15 14:17 EDT by andreas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-19 08:02:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andreas 2000-04-15 14:17:56 EDT
[root@gatekeeper /root]# rpm -q ypserv
ypserv-1.3.9-3

Running /usr/lib/yp/ypinit -m and not entering additional slave servers
generates the following error:

Building /var/yp/zwax/ypservers...
Running /var/yp/Makefile...
gmake[1]: Entering directory `/root'
gmake[1]: ../Makefile: No such file or directory
gmake[1]: *** No rule to make target `../Makefile'.  Stop.
gmake[1]: Leaving directory `/root'
make: *** [target] Error 2
Error running Makefile.
Please try it by hand.

/var/yp/Makefile seems to be broken:
-) it does reference a ../Makefile while there is only one Makefile in
   ypserv.
   [root@gatekeeper /root]# rpm -ql ypserv | grep -i makefile
   /var/yp/Makefile
-) It does not contain a all target, which it seems to reference. All
   available documentation seems to reference all: too, as the target
   where the available maps are configured.

Andreas
Comment 1 Florian La Roche 2000-05-19 08:02:59 EDT
maybe no domainname was set?
Comment 2 andreas 2000-05-19 09:31:59 EDT
Well, at least for me, it seems that some Makefiles are missing.

[andreas@speedy hko]$ ssh root@gate
Last login: Fri May 19 15:26:00 2000 from speedy.zwax.mtg.co.at
You have mail.
[root@gatekeeper /root]# grep domain /etc/yp.conf
#domain NISDOMAIN server HOSTNAME
#       Use server HOSTNAME for the domain NISDOMAIN.
#domain NISDOMAIN broadcast
#       Use  broadcast  on  the local net for domain NISDOMAIN
#       Use server HOSTNAME for the  local  domain.  The
domain zwax
[root@gatekeeper /root]# cd /var/yp/
[root@gatekeeper yp]# make
gmake[1]: Entering directory `/root'
gmake[1]: ../Makefile: No such file or directory
gmake[1]: *** No rule to make target `../Makefile'.  Stop.
gmake[1]: Leaving directory `/root'
make: *** [target] Error 2
[root@gatekeeper yp]# /bin/domainname zwax
[root@gatekeeper yp]# make
gmake[1]: Entering directory `/root'
gmake[1]: ../Makefile: No such file or directory
gmake[1]: *** No rule to make target `../Makefile'.  Stop.
gmake[1]: Leaving directory `/root'
make: *** [target] Error 2
Comment 3 tallen 2000-06-26 14:51:33 EDT
if I do a make i see the above problem; however, if I do a make all it's okay.

Note You need to log in before you can comment on or make changes to this bug.