Bug 108402 - PCI slot directory naming issue
Summary: PCI slot directory naming issue
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 3.0
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Peter Martuccelli
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-29 00:19 UTC by Gary Hade
Modified: 2007-11-30 22:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-22 19:59:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gary Hade 2003-10-29 00:19:03 UTC
Description of problem:
There was a change to the ACPI PCI hotplug driver in 2.4.21 which changed the 
PCI slot directory naming convention 
  from: ACPI<physical slot number>-<bus>:<slot>
  to:   <physical slot number>
The loss of the <bus>:<slot> information makes it much more difficult to locate 
a slot which already contains a specific PCI adapter.  This information 
previously made it easy to associate /sbin/lspci output which containing 
<bus>:<slot> plus an adapter name to the slot where the adapter is located.

The ACPI PCI hotplug maintainer Takayoshi Kochi has been working to provide 
changes which will provide the <bus>:<slot> information in a new file 
named 'address' within each slot directory.  See 
https://sourceforge.net/mailarchive/forum.php?thread_id=3114571&forum_id=765 
for more information.

Version-Release number of selected component (if applicable):
kernel-2.4.21-4.EL, kernel-source-2.4.21-4.EL

How reproducible:
Every time.

Steps to Reproduce:
Note: due to Bug 98504 you will first need to build and install the PCI hotplug 
drivers before performing the following operations.

1. Load the PCI hotplug drivers:
   # modprobe acpiphp
2. Mount the PCI hotplug filesystem: 
   # mount -t pcihpfs none /proc/bus/pci/slots
3. Observe directory names:
   # ls /proc/bus/pci/slots

    
Actual results:
Slot directory names containing only the physical slot numbers.

Expected results:
Directory names including the <bus>:<slot> information.

Additional info:

Comment 3 Jim Paradis 2003-12-08 21:44:00 UTC
I contacted Kochi-san and he sent me his patches, but he warned me
that they don't work on devices with bridges and that they may not be
"Enterprise-ready" as a result.  I'll take a closer look at them and
see what I can do.


Comment 5 Red Hat Bugzilla 2007-03-18 22:16:22 UTC
User jparadis@redhat.com's account has been closed

Comment 6 Peter Martuccelli 2007-03-22 19:59:57 UTC
Closing out as wontfix in R3.9 as it would be a kAPI issue if we changed the
format of /proc/bus/pci/slots.


Note You need to log in before you can comment on or make changes to this bug.