Bug 108425 - missing /usr/share/texmf/tex/latex/listings/listings.sty in package tetex-latex-2.0.2-8
Summary: missing /usr/share/texmf/tex/latex/listings/listings.sty in package tetex-lat...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tetex   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 113600 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-29 12:27 UTC by Moritz Baumann
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version: 2.0.2-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-03 17:58:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the missing listings.sty (64.55 KB, text/plain)
2003-11-06 21:06 UTC, Moritz Baumann
no flags Details

Description Moritz Baumann 2003-10-29 12:27:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031027

Description of problem:
the listings.sty is missing

the file is in tetex-latex-1.0.7-66 (on a redhat 9 system)

I think it's missing because some other files in 

/usr/share/texmf/tex/latex/listings refer to this file and require it

(e.g. lstdoc.sty but its mentioned as required in lstdoc.sty and lstpatch.sty)

Version-Release number of selected component (if applicable):
tetex-latex-2.0.2-8

How reproducible:
Always

Steps to Reproduce:
1. have a latex file containing \usepackage{listings}
2. run "latex <filename>


Actual Results:  ! LaTeX Error: File `listings.sty' not found.
 
Type X to quit or <RETURN> to proceed,
or enter new name. (Default extension: sty)
 
Enter file name:


Expected Results:  it should produce a dvi

Additional info:

after copying listings.sty from Redhat 9 tetex-latex-1.0.7-66 the latex run
complains about: 

(/usr/share/texmf/tex/latex/listings/listings.sty
(/usr/share/texmf/tex/latex/listings/lstpatch.sty
! Undefined control sequence.
l.152 \lst@CheckVersion
                       {1.0}
?

the file lstpatch.sty is not included in the RH9 version of tetex-latex-1.0.7-66

so maybe the listings.sty has changed between RH9 and Fedora

Comment 1 Moritz Baumann 2003-10-29 13:07:43 UTC
I just downloaded the
ftp://tug.ctan.org/tex-archive/systems/unix/teTeX/current/distrib/tetex-texmf-2.0.2.tar.gz

and checked with tar tzf tetex-texmf-2.0.2.tar.gz | grep listings

Result:

[baumannm@schlappy baumannm]$ tar tzf tetex-texmf-2.0.2.tar.gz | grep listings
doc/help/Catalogue/entries/listings.html
doc/latex/listings/
doc/latex/listings/listings.dvi
doc/latex/listings/README
tex/latex/listings/
tex/latex/listings/lstlang1.sty
tex/latex/listings/lstlang2.sty
tex/latex/listings/lstlang3.sty
tex/latex/listings/listings.cfg
tex/latex/listings/lstmisc.sty
tex/latex/listings/lstpatch.sty
tex/latex/listings/lstdoc.sty

Then I checked with the tetex-mailing list archives:

http://www.mail-archive.com/tetex%40informatik.uni-hannover.de/msg01873.html

and

http://www.mail-archive.com/tetex%40informatik.uni-hannover.de/msg01874.html

so now I downloaded 

ftp://dante.ctan.org/tex-archive/systems/unix/teTeX/current/distrib/tetex-texmfsrc-2.0.2.tar.gz

and got the missing file from there. Now everything works fine.



Comment 2 Moritz Baumann 2003-11-06 21:06:00 UTC
Created attachment 95773 [details]
the missing listings.sty

this is the original file from texmfsrc-2.0.2.tar.gz 
you can get it from the tarball at a ctan mirror (e.g.):
ftp://ftp.dante.de/pub/tex/systems/unix/teTeX/2.0/distrib/\
tetex-texmfsrc-2.0.2.tar.gz

all one needs to do is get the contained listings.sty and copy it to
/usr/share/texmf/tex/latex/listings/listings.sty
(I did a texhash afterwards but I do not know if this is necessary).

no recompile, etc.

Comment 3 Tim Waugh 2003-11-07 11:00:15 UTC
Thanks, fixed in CVS.

Comment 4 Tim Waugh 2004-01-15 23:29:46 UTC
*** Bug 113600 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.