Bug 108429 - /sbin/ifup executes dhclient with -1, so that it quits when dhcps is down
/sbin/ifup executes dhclient with -1, so that it quits when dhcps is down
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-29 09:05 EST by Tulipánt Gergely
Modified: 2014-03-16 22:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: FC4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 16:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tulipánt Gergely 2003-10-29 09:05:06 EST
Description of problem:

  If the DHCP server is not accessible when dhclient is trying to renew the
lease, dhclient quits, so your interface loses its IP address. You have to ifup
manually.

How reproducible:


Steps to Reproduce:
1. Set up a short lease time on the server. Ifup on the client.
2. Disconnect the dhcp server from the client.
3. Notice that dhclient quits when the lease expires, and it can't renew.
Comment 1 Adam Gibson 2004-02-14 02:25:51 EST
I have had to rescue quite a few systems because of this issue(fedora
core 1 has the same problem).  Not everyone has the time to keep tabs
on all the firewall systems they deploy to bring the network up when
dhclient quits because the lease expires.

It would be nice to have a -2 option for dhclient that causes dhclient
to fail if it first can not get a lease, but once it does get that
first IP it will always attempt to even on expire.

That way network scripts get the feedback they need(pass or fail) and
users get what they need( an interface that never gives up trying to
get an IP once it acquires one initially).

I wonder what the chances are of getting ISC to accept a patch for
that?  I am rather suprised nobody else has done that yet.
Comment 2 Bill Nottingham 2005-09-30 16:00:14 EDT
Current releases have support for a PERSISTENT_DHCLIENT; this may solve your needs.

Note You need to log in before you can comment on or make changes to this bug.