Bug 10845 - BuildPreReq: pciutils-devel missing.
Summary: BuildPreReq: pciutils-devel missing.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kudzu   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-16 00:35 UTC by Pekka Savola
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 15:25:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-04-16 00:35:28 UTC
(kudzu-0.36-2)

BuildPreReq: pciutils-devel is missing.

Also, it seems mouseconfig srpm has the whole kudzu inside it.  Makes one
wonder why.


Btw, kudzu's ktest doesn't compile on glibc20 system (heavily updated RH51)
-- well, I don't think it was meant to :/

cc -O2 -m486 -fno-strength-reduce -Wall -D_GNU_SOURCE -DVERSION=\"0.36\"
-I/usr/include/python1.5  hwconf.o  -o kudzu -L. -lkudzu -lmodules -lpci
-lnewt -lslang -lpopt
./libkudzu.a(serial.o): In function `serialProbe':
serial.o(.text+0x1378): undefined reference to `major'
serial.o(.text+0x143f): undefined reference to `major'
make: *** [kudzu] Error 1

Comment 1 Bill Nottingham 2000-04-17 15:25:59 UTC
The buildprereq has been added; thanks for the report.

The mouse/x config RPMs have kudzu in them because if
they include the latest CVS module, you'll know they always
get built with the latest code. If we ever move to shipping
kudzu as a shared library, this will probably change.

As for the compilation problem, add '#include <sys/sysmacros.h>'
to serial.c, this will be fixed in 0.39 when it is released.


Note You need to log in before you can comment on or make changes to this bug.