Bug 108459 - rpm hangs during execution
rpm hangs during execution
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-29 14:16 EST by Need Real Name
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-30 07:28:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-10-29 14:16:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Description of problem:

I've installed the apt package from freshrpms.net. This problem
also occurs on normal rpm operations though.

[root@yoda root]# apt-get install mysql php-mysql mysql-devel
Reading Package Lists... Done
Building Dependency Tree... Done
mysql is already the newest version.
php-mysql is already the newest version.
The following NEW packages will be installed:
  mysql-devel
0 packages upgraded, 1 newly installed, 0 removed and 2 not upgraded.
Need to get 581kB of archives.
After unpacking 1521kB of additional disk space will be used.
Get:1 http://ayo.freshrpms.net redhat/9/i386/updates mysql-devel 3.23.58-1.9 [58
1kB]
Fetched 581kB in 23s (24.9kB/s)
Executing RPM (-Uvh)...
Preparing...                ########################################### [100%]
   1:mysql-devel            ########################################### [100%]


And then nothing happens. No response for CTRL-C. kill -9 works.
Once a hang has happened, all subsequent rpm functions hang. Reboot
required to use rpm again, and then eventually it begins to hang
once more.

There's nothing in the logs (I may be looking in the wrong ones 
though, but nothing suspicious in /var/log)

[root@yoda root]# uname -a
Linux yoda 2.4.20-18.9 #1 Thu May 29 07:08:16 EDT 2003 i686 i686 i386 GNU/Linux


Version-Release number of selected component (if applicable):
rpm-4.2-0.69.i386.rpm

How reproducible:
Sometimes

Steps to Reproduce:
1. I cannot reproduce every time.
2. I just install using -Uvh, and after that, even -qa cause hang

    

Actual Results:  As described

Expected Results:  Installation to complete

Additional info:
Comment 1 Jeff Johnson 2003-10-30 07:28:35 EST
Yup, unhandled SIGPIPE can leave stale locks.

All that the reboot did was
    rm -f /var/lib/rpm/__db*
Easier to just do that than reboot.

SIGPIPE problem fixed in rpm-4.1-1 packages at
    ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.2.x
Comment 2 Mike Minnich 2003-11-06 22:37:48 EST
I've run into this problem also, RH 9.0 with all the latest upgrades
installed plus rpm-4.2.1 and rpm still experiences hangs. There are
instances where running a simple rpm -Uvh with 1 .rpm completes
successfully but leaves behind /var/lib/rpm/__db* when they did not
exists prior to running rpm. Subsequent rpm invocations can run OK.  

For some reason, one rpm that really seemed to trip over this problem
was redhat-config-date-1.5.15-1.noarch.rpm.

Running a number of rpm commands in series (such as from autoupdate)
appear to cause the problem.

Note You need to log in before you can comment on or make changes to this bug.