Bug 108485 - contacts lost when upgrading evolution
Summary: contacts lost when upgrading evolution
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-29 23:16 UTC by Dave Maley
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-03 19:02:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Maley 2003-10-29 23:16:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031027

Description of problem:
The last 2 times I've updated my fedora system the evolution upgrade caused me
to lose the contents on my Contacts folder.

I've tried removing the .summary file but that didn't help.  The contacts are lost.

Version-Release number of selected component (if applicable):
evolution-1.4.5-7

How reproducible:
Always

Steps to Reproduce:
1. install Fedora B3
2. point up2date at rawhide or porkchop.redhat.com/test/yarrow-yum
3. up2date (including evolution)
    

Actual Results:  contents of the Contacts folder are gone.

Expected Results:  Contacts survive upgrade.

Additional info:

This has happened when going from 1.4.5-2 -> 1.4.5-5 and when going from 1.4.5-5
-> 1.4.5-7.

Additionally, I recreated the Contacts manually under 1.4.5-5 so I wouldn't
think there's any problems w/ version conflicts ...

Comment 1 Jeremy Katz 2003-11-03 04:07:55 UTC
Hmmm, I seem to still have all of my contacts.  Are you just adding
them and then upgrading without exiting in between?  If so, the wombat
might possibly get force killed on the new version starting before
things get synced to disk?

Comment 2 Dave Maley 2003-11-03 19:02:27 UTC
Well, it appears I'm not able to reproduce this.  I reverted back to
1.4.5-2 and then upgraded to 1.4.5-5 - contacts still present.  I then
up2dated via yum to 1.4.5-7, and the contacts were still there.

Not sure if I had evo open during updates, although I doubt it.  And I
know I closed and re-opened evo after re-creating the contacts under
1.4.5-5, so they would have been written to disk.

Anyway, since this doesn't appear to be reproducable I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.