Bug 108498 - Up2date fails with rpm.error: public key not trusted
Up2date fails with rpm.error: public key not trusted
Status: CLOSED DUPLICATE of bug 108454
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-29 19:56 EST by Rex Basham
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rex Basham 2003-10-29 19:56:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031027

Description of problem:
Attempting to install redhat-config-network and redhat-config-network-tui, both
at 1.3.10-1.  

Retrieval works fine, but up2date hangs on the Installing Packages screen.

Tried it both with and without GPG enabled, same results.  Only difference with
GPG enabled is a question box, are you sure...etc.

Version-Release number of selected component (if applicable):
redhat-config-network 1.3.10-1

How reproducible:
Always

Steps to Reproduce:
1. launch up2date
2. retrieve the packages 
3. try to install
    

Actual Results:  hang in up2date for the untrusted public key.

Expected Results:  packages installed.

Additional info:

Traceback:
[root@asusa7n8x rexb]# up2date
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 2070, in doInstallation
    kernelsToInstall = up2date.installPackages(self.selectedPkgList,
self.rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 604, in installPackages
    hdr = getRealHeader(pkg)
  File "/usr/share/rhn/up2date_client/up2date.py", line 173, in getRealHeader
    hdr = _ts.hdrFromFdno(fd)
rpm.error: public key not trusted
Comment 1 Don Himelrick 2003-10-30 06:51:50 EST
Duplicate of Bug 108454
Comment 2 Hamilton Leeper 2003-10-31 09:34:30 EST
I tried using up2date this morning and I got the same result:

[root@laptop grinch]# up2date
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 2070, in doInstallation
    kernelsToInstall = up2date.installPackages(self.selectedPkgList,
self.rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 613, in installPackages
    hdr = getRealHeader(pkg)
  File "/usr/share/rhn/up2date_client/up2date.py", line 173, in getRealHeader
    hdr = _ts.hdrFromFdno(fd)
rpm.error: public key not trusted
Comment 3 Adrian Likins 2004-08-24 16:40:40 EDT

*** This bug has been marked as a duplicate of 108454 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:59:33 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.