Bug 10850 - After man page gzip stage, packages with symlinked manpages are't backward-compatible
Summary: After man page gzip stage, packages with symlinked manpages are't backward-co...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fetchmail   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-16 08:44 UTC by Pekka Savola
Modified: 2016-10-18 02:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-05 18:07:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pekka Savola 2000-04-16 08:44:23 UTC
RPM's rebuilt with rpm 3.0.2-5x from newer src.rpm's (after man page
gzipping stage) have to be fixed manually if there are symlinked manpages
in the packages.

Doing things like this in spec file make it go wrong:
----
ln -sf fetchmail.1.gz $RPM_BUILD_ROOT/usr/man/man1/fetchmailconf.1.gz
----

And after that, whatis database and the man page are inaccessible.
Gzipping the man page (here fetchmail.1) fixes this.
----
root: /$ makewhatis
zcat: ./fetchmailconf.1.gz: No such file or directory
----

Because gzipping the man pages seems to be an internal function of RPM,
perhaps there should also be a macro for symlinking the pages.

Just thought to bring this into attention -- as upgrading rpm seems to be
the only way to go here anyway (however see bug #10763).

Comment 1 Jeff Johnson 2000-05-05 18:07:59 UTC
This is a problem with fetchmail src rpm packaging, not rpm.
Changing component...

Comment 2 Nalin Dahyabhai 2000-07-10 22:07:09 UTC
This was fixed some time ago in the fetchmail package by
changing the fetchmailconf page from a symlink to a file that
references fetchmail's.  If you find this problem in other
packages, please report it as a bug.

Thanks!

Comment 3 openshift-github-bot 2016-10-18 02:45:57 UTC
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/94097880f8c57c73be8768af243a3586c07804b3
Merge pull request #11219 from jim-minter/issue10850

Merged by openshift-bot


Note You need to log in before you can comment on or make changes to this bug.