Bug 10854 - Can't make Etherlink III ISA cards to work *after* install
Can't make Etherlink III ISA cards to work *after* install
Status: CLOSED DUPLICATE of bug 10632
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-16 08:49 EDT by Gustav Schaffter
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 11:16:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gustav Schaffter 2000-04-16 08:49:40 EDT
The 3Com Ehterlink III ISA 10Mb card (509) works fine during an ftp
installation, but fails to work when the system is booted up for use.

In /var/log/boot.log I find the messages:

network: setting network parameters succeeded
ifup: SIOCADDRT: Network is unreachable
network: Bringing up interface lo succeeded
ifup: Delaying eth0 initialization
network: Bringing up interface eth0 failed

I can't find any other related messages anywhere.

When it works (during installation) the led on the hub is lit. When it
doesn't work, the led on the hub does not light up.

I've tried four different cards. (Three combo cards (yes, they are set to
use RJ-45) and one RJ-45 only card.)

Done this in four different PCs, three 486 and one P100. Tried all
combinations of I/O address and IRQ levels. Machines are 'empty' except for
VGA and IDE controllers.

These are 'new' machines, i.e. I did 'custom install' not upgrade.

Of course, I'm ready to provide any additional information, should that be
requested.

Best regards
Gustav

P.S. My wife is upset that I've spent about ten evenings and two complete
week-ends to get this far and it still doesn't work. But I don't think you
may change that. :-)
Comment 1 Jay Turner 2000-04-17 10:50:59 EDT
Please send the output of your /etc/conf.modules file.  It sounds like the
parameters of the cards are not getting written to your /etc/conf.modules file
correctly.
Comment 2 Gustav Schaffter 2000-04-17 13:57:59 EDT
Looks like it. The contents of /etc/conf.modules:

alias parport_lowlevel parport_pc

That's all!

I guess (from your request) that the installation routine should have added some
parameters for eth0 here as well.
What parameters would that be?

Gustav
Comment 3 Gustav Schaffter 2000-04-17 15:59:59 EDT
Of course. Found it.

The installer forgot to enter:
alias eth0 3c509

in all machines. There's the bug.

Gustav
Comment 4 Jay Turner 2000-04-18 09:10:59 EDT
Forwarding this issue to a developer for further action.
Comment 5 Jay Turner 2000-04-24 11:16:59 EDT
*** This bug has been marked as a duplicate of 10632 ***

Note You need to log in before you can comment on or make changes to this bug.