Bug 1085465 - system groups on activation key not being associated with registered system
Summary: system groups on activation key not being associated with registered system
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Registration
Version: Nightly
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-04-08 16:35 UTC by Tom McKay
Modified: 2019-09-26 14:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-02 14:09:24 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
the content-host which got created under host-collections (89.49 KB, image/png)
2014-05-13 14:55 UTC, Kedar Bidarkar
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 5116 0 None None None 2016-04-22 16:29:15 UTC

Description Tom McKay 2014-04-08 16:35:53 UTC
To reproduce: Assign a system group to an activation key, then use that key to register a system. Note that the registered system is not in the system group.

Comment 1 Tom McKay 2014-04-08 16:41:32 UTC
Created redmine issue http://projects.theforeman.org/issues/5116 from this bug

Comment 3 Bryan Kearney 2014-04-23 11:39:46 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/5116 has been closed

Comment 5 Kedar Bidarkar 2014-05-13 14:51:48 UTC
1) created an activation-key and assigned a host-collection to it,
2) Registered a host with the above activation-key.
3) Upon registering the host does get added to the host-collection assigned to the ak in step 1)


[root@xxxx ~]# subscription-manager register --org ACME_Corporation --activationkey test_hostcoll_ak
The system has been registered with ID: d3dab85f-0b50-4217-bf45-b816f398aa40 


attaching the host-collection association screen-shot shortly.

Comment 6 Kedar Bidarkar 2014-05-13 14:55:35 UTC
Created attachment 895169 [details]
the content-host which got created under host-collections

Comment 7 Bryan Kearney 2014-07-02 14:09:22 UTC
This was delivered in 6.0.3, the Beta version of Satellite 6.0

Comment 8 Bryan Kearney 2014-07-02 14:09:24 UTC
This was delivered with 6.0.3, which is the Satellite 6 Beta.


Note You need to log in before you can comment on or make changes to this bug.