Bug 10858 - Errata /etc/rc.d/rc.sysinit
Summary: Errata /etc/rc.d/rc.sysinit
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-16 15:45 UTC by claudeg
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-17 15:04:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description claudeg 2000-04-16 15:45:30 UTC
With modutils 2.3.9 the file /etc/rc.d/rc.sysinit is wrong because it
uses the file /etc/conf.modules instead of /etc/modules.conf
Also:

---------------------------------cut here--------------------------------
# Load sound modules
#
# I think this now qualifies as over-engineered.
RETURN=0
alias=`egrep -s "^alias[[:space:]]+sound[[:space:]]+" /etc/conf.modules | a
wk '{ print $3 }'`
if [ -n "$alias" -a "$alias" != "off" ] ; then
      action "Loading sound module ($alias)" modprobe $alias
      RETURN=$?
fi
alias=`egrep -s "^alias[[:space:]]+sound-slot-0[[:space:]]+" /etc/conf.modu
les | awk '{ print $3 }'`
if [ -n "$alias" -a "$alias" != "off" ] ; then
      action "Loading sound module ($alias)" modprobe $alias
      RETURN=$?
fi
alias=`egrep -s "^alias[[:space:]]+midi[[:space:]]+" /etc/conf.modules | aw
k '{ print $3 }'`
if [ -n "$alias" -a "$alias" != "off" ]; then
      action "Loading midi module ($alias)" modprobe $alias
fi
-----------------------------------------cut here------------------------

I have a AWE32 PnP SoundBlaster card.
To load midi module, the correct line is:

alias=`egrep -s "^alias[[:space:]]+sound-service-0-1[[:space:]]+" ....

and NOT:

alias=`egrep -s "^alias[[:space:]]+midi[[:space:]]+" ....

because in /etc/modules.conf must be present:

alias sound-service-0-1 awe_wave


Ciao
Ale

Comment 1 Bill Nottingham 2000-04-17 15:04:59 UTC
It uses conf.modules for backwards compatibility with the  rest
of the 6.x series; that was determined to be too large of a change
for a point release. This will be changed for the next major release.

If you have the sound-service entry, it should load on demand
OK anyways; the 'modprobe midi' was there mainly for legacy
cards that needed ISA buffers removed. Still, we'll change
this for the next sndconfig/kudzu/whatever we use for that.


Note You need to log in before you can comment on or make changes to this bug.