Bug 108582 - switchdesk writes incorrect ~/.Xclients-$HOSTAME$DISPLAY
switchdesk writes incorrect ~/.Xclients-$HOSTAME$DISPLAY
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: switchdesk (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 07:18 EST by Don Himelrick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-03 16:32:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Himelrick 2003-10-30 07:18:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031027

Description of problem:
switchdesk produces a file in your home directory named

.Xclients-masta1.don:1.0

and an .Xclients file that that looks for  ~/.Xclients-$HOSTAME$DISPLAY
which on my system expands to  .Xclients-masta1.don:1


Since the file doesn't exits, it fails the  if [ -e ] and .Xclients defaults to
~/.Xclients-default, which doesn't exist either. Kaboom!

Rename Xclients-masta1.don:1.0 to Xclients-masta1.don:1 and everything works.

BTW, I did this on Alt-F8, using startx -- :1, with Alt-F7 already running an X
session. I ran switchdesk-gnome and chose "for the current display only" and
saved. When I tried regular old startx again with no X  display running, it
crashed because there was (correctly) no Xclients-masta1.don:0 file and because
(incorrectly?) there was no .Xclients-default.


Version-Release number of selected component (if applicable):
switchdesk-3.9.8-18

How reproducible:
Always

Steps to Reproduce:
1. See above
2.
3.
    

Additional info:
Comment 1 Ngo Than 2004-02-03 16:32:23 EST
it's fixed in 4.0.0, which is available in rawhide


Note You need to log in before you can comment on or make changes to this bug.