Bug 108589 - up2date traceback before even downloading rpms
Summary: up2date traceback before even downloading rpms
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: up2date   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Fanny Augustin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-30 14:03 UTC by Chris Ricker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-30 17:18:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2003-10-30 14:03:36 UTC
[kaboom@skuld up2date]$ sudo rm /var/spool/up2date/*
[kaboom@skuld up2date]$ sudo up2date --nox -u --nosig

Fetching package list for channel: rawhide...

Fetching http://ftp.redhat.com/pub/redhat/linux/rawhide//headers/header.info...
########################################
#######################################
Fetching Obsoletes list for channel: rawhide...

Fetching obsoletes list for http://ftp.redhat.com/pub/redhat/linux/rawhide/...
#######################################
Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
FreeWnn-libs                            1.11           39                  i386  
abiword                                 2.0.1          1                   i386  
<snip>
up2date-gnome                           4.1.14         2                   i386  
yum                                     2.0.4          2                   noarch

Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1187, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 765, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1050, in batchRun
    batch.run()
  File "up2dateBatch.py", line 70, in run
  File "up2dateBatch.py", line 142, in __dryRun
  File "up2date.py", line 341, in dryRun
ValueError: list.remove(x): x not in list
[kaboom@skuld up2date]$ 

The only thing in /var/spool/up2date at this point are header files.

up2date-4.1.12-1

Comment 1 Chris Ricker 2003-10-30 14:06:04 UTC
Might be duplicate of Bug #108401

I only have one kernel installed, though, so maybe not

Comment 2 Chris Ricker 2003-10-30 17:18:25 UTC
Whatever the problem, upgrading to up2date-4.1.14-2 fixed it


Note You need to log in before you can comment on or make changes to this bug.