Bug 10861 - kernel hangs on streamer w/ Qlogic ISP1020 driver
kernel hangs on streamer w/ Qlogic ISP1020 driver
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-16 13:55 EDT by paluch
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-22 01:11:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description paluch 2000-04-16 13:55:41 EDT
The kernel (from RedHat 6.1 and 6.2) locks up on boot if these two
conditions are met:
1) compiled in SCSI streamer support
AND
2) There is defined
   #define RELOAD_FIRMWARE         1
   in qlogicisp.c (defined as default on standard kernels)

The lockup occurs on SCSI devices detection (right before attempt
to detect the streamer).

The problem did not appeared in RedHat 5.2 kernel, because there was
not compiled in streamer support (in Alpha version of kernels).

Solution: Do not #define RELOAD_FIRMWARE 1

Here is a log of a typical boot:

qlogicisp : new isp1020 revision ID (5)
scsi0 : QLogic ISP1020 SCSI on PCI bus 00 device 28 irq 17 I/O base 0x9000
scsi : 1 host.
  Vendor: DEC       Model: RZ1CB-CS (C) DEC  Rev: 0656
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sda at scsi0, channel 0, id 0, lun 0
  Vendor: DEC       Model: RZ1CB-CS (C) DEC  Rev: 0656
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdb at scsi0, channel 0, id 1, lun 0
  Vendor: DEC       Model: RZ1CB-CS (C) DEC  Rev: 0656
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdc at scsi0, channel 0, id 2, lun 0
  Vendor: DEC       Model: RZ1CB-CS (C) DEC  Rev: 0656

  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected scsi disk sdd at scsi0, channel 0, id 3, lun 0
  Vendor: DEC       Model: RRD46   (C) DEC   Rev: 0557
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 4, lun 0
----> if RELOAD_FIRMWARE, the kernel hangs here <-----------
  Vendor: DEC       Model: TLZ09     (C)DEC  Rev: 0173
  Type:   Sequential-Access                  ANSI SCSI revision: 02
Detected scsi tape st0 at scsi0, channel 0, id 6, lun 0
scsi : detected 1 SCSI tape 1 SCSI cdrom 4 SCSI disks total.
Uniform CDROM driver Revision: 2.56
SCSI device sda: hdwr sector= 512 bytes. Sectors= 8380080 [4091 MB] [4.1
GB]
SCSI device sdb: hdwr sector= 512 bytes. Sectors= 8380080 [4091 MB] [4.1
GB]
SCSI device sdc: hdwr sector= 512 bytes. Sectors= 8380080 [4091 MB] [4.1
GB]
SCSI device sdd: hdwr sector= 512 bytes. Sectors= 8380080 [4091 MB] [4.1
GB]
Partition check:
 sda: sda1 sda3
 sdb: sdb1
 sdc: sdc1 sdc2 sdc3
 sdd: sdd1
Comment 1 Doug Ledford 2000-04-22 01:11:59 EDT
The default Red Hat kernels on the Alpha (as of 6.2 anyway, I didn't have
anything to do with the 6.1 Alpha kernels) do not have the st module compiled
into the kernel, but as a separate module.  Are you seeing this problem on
custom compiled kernels or on the Red Hat supplied kernels?
Comment 2 Alan Cox 2000-08-08 16:54:32 EDT
No answer so closing

Note You need to log in before you can comment on or make changes to this bug.