Bug 108621 - RFE: tcl-devel & tk-devel packages are missing from the distribution
RFE: tcl-devel & tk-devel packages are missing from the distribution
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: tcltk (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Bill Huang
: FutureFeature
: 116687 119245 119282 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-30 14:09 EST by Jim Levie
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 01:20:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Levie 2003-10-30 14:09:03 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The -devel components of tcl & tk aren't included with the 3.0 ES distribution.
This results in not being able to build anything that needs the tcl and/or tk
header files or libraries. 

Version-Release number of selected component (if applicable):
tcl-8.3.5-92 & tk-8.3.5-92

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild rh-postgresql-7.3.4-8.src.rpm
    

Actual Results:  A build of anything that needs access to the -devel components
of tcl or tk will will fail. In this particular case rh-postgresql needs to
build rh-postgresql-tcl, which fails aborting the build.

Expected Results:  A build of a something that depends on tcl-devel and/or
tk-devel should work if those packages are present in the distribution and
installed.

Additional info:

The workaround is pretty easy. The missing packages can be built and installed
from the tcltk-8.3.5-92.src.rpm. however, that shouldn't be necessary and the
components should be in the 3.0 ES distribution.
Comment 1 dff 2003-10-30 19:06:35 EST

*** This bug has been marked as a duplicate of 108668 ***
Comment 2 Kyle Powell 2003-11-10 14:47:18 EST
I think it should also be noted that:

[root@rhel3 root]# rpm --redhatprovides /usr/include/tcl.h
tcl-devel-8.3.5-92

yet the package does not exist.
Comment 3 Jens Petersen 2004-02-24 21:11:48 EST
*** Bug 116687 has been marked as a duplicate of this bug. ***
Comment 4 Jens Petersen 2004-03-29 07:54:33 EST
*** Bug 119245 has been marked as a duplicate of this bug. ***
Comment 5 Jens Petersen 2004-03-29 07:55:55 EST
Re-opening this bug until the tcltk -devel packages are actually
released.
Comment 6 Jens Petersen 2004-03-29 07:58:50 EST
*** Bug 119282 has been marked as a duplicate of this bug. ***
Comment 7 Jens Petersen 2004-06-24 01:20:30 EDT
AFAIK the -devel packages are now available in a channel on RHN.
Please re-open if that is not the case.

Note You need to log in before you can comment on or make changes to this bug.